aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/xcb_proto.mk
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-07-18 11:27:09 +0100
committerfanquake <fanquake@gmail.com>2023-07-18 11:27:24 +0100
commit7cb88c8b46723d306b96953a6a60c90a4ab211e3 (patch)
tree03665fbc0badf2920cdf6df0eef1baca2aa6f5f7 /depends/packages/xcb_proto.mk
parent673acab223c0f896767b1ae784659df9f95452ae (diff)
depends: xcb-proto 1.15.2
Resolves build failures under Python 3.12, i.e building on rawhide: ```bash make[3]: Nothing to be done for 'install-exec-am'. /usr/bin/mkdir -p '/bitcoin/depends/work/staging/aarch64-unknown-linux-gnu/xcb_proto/1.14.1-4a91ac9dc41/bitcoin/depends/aarch64-unknown-linux-gnu/lib/python3.12/site-packages/xcbgen' /usr/bin/install -c -m 644 __init__.py error.py expr.py align.py matcher.py state.py xtypes.py '/bitcoin/depends/work/staging/aarch64-unknown-linux-gnu/xcb_proto/1.14.1-4a91ac9dc41/bitcoin/depends/aarch64-unknown-linux-gnu/lib/python3.12/site-packages/xcbgen' Traceback (most recent call last): File "<string>", line 2, in <module> ModuleNotFoundError: No module named 'imp' make[3]: *** [Makefile:271: install-pkgpythonPYTHON] Error 1 ``` `imp` was removed in 3.12: https://docs.python.org/3/library/imp.html.
Diffstat (limited to 'depends/packages/xcb_proto.mk')
-rw-r--r--depends/packages/xcb_proto.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/depends/packages/xcb_proto.mk b/depends/packages/xcb_proto.mk
index 9be822506d..6e1c5a10a8 100644
--- a/depends/packages/xcb_proto.mk
+++ b/depends/packages/xcb_proto.mk
@@ -1,8 +1,8 @@
package=xcb_proto
-$(package)_version=1.14.1
+$(package)_version=1.15.2
$(package)_download_path=https://xorg.freedesktop.org/archive/individual/proto
$(package)_file_name=xcb-proto-$($(package)_version).tar.xz
-$(package)_sha256_hash=f04add9a972ac334ea11d9d7eb4fc7f8883835da3e4859c9afa971efdf57fcc3
+$(package)_sha256_hash=7072beb1f680a2fe3f9e535b797c146d22528990c72f63ddb49d2f350a3653ed
define $(package)_config_cmds
$($(package)_autoconf)