aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/packages.mk
diff options
context:
space:
mode:
author0xb10c <0xb10c@gmail.com>2021-12-07 14:46:48 +0100
committer0xb10c <0xb10c@gmail.com>2022-01-04 10:13:24 +0100
commite158a2a7aa501da635cb34414abd0c092216e5f4 (patch)
tree0d1fdaff2e5b086e2a544fddaef04145b72478a4 /depends/packages/packages.mk
parent38146a4bd2e55973dbc7c4716b1815e204adbf84 (diff)
downloadbitcoin-e158a2a7aa501da635cb34414abd0c092216e5f4.tar.xz
build: add systemtap's sys/sdt.h as depends
The sys/sdt.h header is required to build Bitcoin Core with Userspace Statically Defined Tracing support. Systemtap version 4.5 (May 2021) is used as the most recent version 4.6 (Nov 2021) fails to build. See e.g. https://sourceware.org/git/?p=systemtap.git;a=commit;h=1d3653936fc1fd13135a723a27e6c7e959793ad0 As Systemtap itself is not needed, the build steps (configure and make) are skipped. We require fewer build dependecies and don't waste time building depends we don't end up using. However, the configure step would normally processes sys/sdt-config.h.in. The resulting sdt-config.h defines _SDT_ASM_SECTION_AUTOGROUP_SUPPORT (either 0 or 1 to indicate whether the assembler supports "?" in .pushsection directives). For now, we assume all currently used assemblers supports this feature and remove the check from the sys/sdt.h header file in a patch. Co-authored-by: Michael Ford <fanquake@gmail.com>
Diffstat (limited to 'depends/packages/packages.mk')
-rw-r--r--depends/packages/packages.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/depends/packages/packages.mk b/depends/packages/packages.mk
index 426fa2e748..77866c8e7a 100644
--- a/depends/packages/packages.mk
+++ b/depends/packages/packages.mk
@@ -19,6 +19,8 @@ natpmp_packages=libnatpmp
multiprocess_packages = libmultiprocess capnp
multiprocess_native_packages = native_libmultiprocess native_capnp
+usdt_linux_packages=systemtap
+
darwin_native_packages = native_ds_store native_mac_alias
$(host_arch)_$(host_os)_native_packages += native_b2