aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/native_biplist.mk
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2019-03-14 15:08:54 -0400
committerMarcoFalke <falke.marco@gmail.com>2019-03-14 15:47:00 -0400
commitfa0f92af9ae35c0e6c8068241ff7a34b06d1a262 (patch)
treef8ea9f5e2c2c2c1dec666bd9abee9f3405158766 /depends/packages/native_biplist.mk
parent887f57eb727643eb1f37999a022f3817aaab6d00 (diff)
downloadbitcoin-fa0f92af9ae35c0e6c8068241ff7a34b06d1a262.tar.xz
build: depends: Switch to python3
Diffstat (limited to 'depends/packages/native_biplist.mk')
-rw-r--r--depends/packages/native_biplist.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/depends/packages/native_biplist.mk b/depends/packages/native_biplist.mk
index 5f247e9bf3..c3054cbd1a 100644
--- a/depends/packages/native_biplist.mk
+++ b/depends/packages/native_biplist.mk
@@ -3,13 +3,13 @@ $(package)_version=1.0.3
$(package)_download_path=https://bitbucket.org/wooster/biplist/downloads
$(package)_file_name=biplist-$($(package)_version).tar.gz
$(package)_sha256_hash=4c0549764c5fe50b28042ec21aa2e14fe1a2224e239a1dae77d9e7f3932aa4c6
-$(package)_install_libdir=$(build_prefix)/lib/python/dist-packages
+$(package)_install_libdir=$(build_prefix)/lib/python3/dist-packages
define $(package)_build_cmds
- python setup.py build
+ python3 setup.py build
endef
define $(package)_stage_cmds
mkdir -p $($(package)_install_libdir) && \
- python setup.py install --root=$($(package)_staging_dir) --prefix=$(build_prefix) --install-lib=$($(package)_install_libdir)
+ python3 setup.py install --root=$($(package)_staging_dir) --prefix=$(build_prefix) --install-lib=$($(package)_install_libdir)
endef