aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/native_biplist.mk
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2016-07-20 09:09:26 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2016-07-20 09:10:18 +0200
commitc98abf2c7099fa089cd9170dcdd118ba86356ffc (patch)
tree3257ce549fdaf6d8aba898d0cd9152b2d1779924 /depends/packages/native_biplist.mk
parent045106b4f13c1d6f3a4f65d6dddc6ac1e15003bb (diff)
parent3b3ce25df6cc84cd1e75a7ec20fc7da8d2ef76e0 (diff)
downloadbitcoin-c98abf2c7099fa089cd9170dcdd118ba86356ffc.tar.xz
Merge #8373: Fix OSX non-deterministic dmg
3b3ce25 build: fix non-deterministic biplist (Cory Fields)
Diffstat (limited to 'depends/packages/native_biplist.mk')
-rw-r--r--depends/packages/native_biplist.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/depends/packages/native_biplist.mk b/depends/packages/native_biplist.mk
index eb8672d556..3c6e8900f6 100644
--- a/depends/packages/native_biplist.mk
+++ b/depends/packages/native_biplist.mk
@@ -4,6 +4,11 @@ $(package)_download_path=https://pypi.python.org/packages/source/b/biplist
$(package)_file_name=biplist-$($(package)_version).tar.gz
$(package)_sha256_hash=b57cadfd26e4754efdf89e9e37de87885f9b5c847b2615688ca04adfaf6ca604
$(package)_install_libdir=$(build_prefix)/lib/python/dist-packages
+$(package)_patches=sorted_list.patch
+
+define $(package)_preprocess_cmds
+ patch -p1 < $($(package)_patch_dir)/sorted_list.patch
+endef
define $(package)_build_cmds
python setup.py build