aboutsummaryrefslogtreecommitdiff
path: root/contrib/guix/patches
diff options
context:
space:
mode:
authorAndrew Chow <achow101-github@achow101.com>2022-07-06 17:24:20 -0400
committerAndrew Chow <achow101-github@achow101.com>2022-07-06 17:24:20 -0400
commit5bff18bce5d9d8bd1bae0cb89facf73c829c947b (patch)
tree043984457e20471143a1e24e2f20e40134476382 /contrib/guix/patches
parentaeab1b42e67cc8146bfc7d127d15633bd652fe60 (diff)
downloadbitcoin-5bff18bce5d9d8bd1bae0cb89facf73c829c947b.tar.xz
guix: patch gcc 10 with pthreads to remap guix store paths
Diffstat (limited to 'contrib/guix/patches')
-rw-r--r--contrib/guix/patches/gcc-10-remap-guix-store.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/contrib/guix/patches/gcc-10-remap-guix-store.patch b/contrib/guix/patches/gcc-10-remap-guix-store.patch
new file mode 100644
index 0000000000..a47ef7a2df
--- /dev/null
+++ b/contrib/guix/patches/gcc-10-remap-guix-store.patch
@@ -0,0 +1,25 @@
+From aad25427e74f387412e8bc9a9d7bbc6c496c792f Mon Sep 17 00:00:00 2001
+From: Andrew Chow <achow101-github@achow101.com>
+Date: Wed, 6 Jul 2022 16:49:41 -0400
+Subject: [PATCH] guix: remap guix store paths to /usr
+
+---
+ libgcc/Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libgcc/Makefile.in b/libgcc/Makefile.in
+index 851e7657d07..476c2becd1c 100644
+--- a/libgcc/Makefile.in
++++ b/libgcc/Makefile.in
+@@ -854,7 +854,7 @@ endif
+ # libgcc_eh.a, only LIB2ADDEH matters. If we do, only LIB2ADDEHSTATIC and
+ # LIB2ADDEHSHARED matter. (Usually all three are identical.)
+
+-c_flags := -fexceptions
++c_flags := -fexceptions $(shell find /gnu/store -maxdepth 1 -mindepth 1 -type d -exec echo -n " -ffile-prefix-map={}=/usr" \;)
+
+ ifeq ($(enable_shared),yes)
+
+--
+2.37.0
+