aboutsummaryrefslogtreecommitdiff
path: root/contrib/guix/manifest.scm
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-11-13 13:24:05 +0000
committerfanquake <fanquake@gmail.com>2023-11-13 16:44:17 +0000
commitd3cbff16c2734f310ccc532a4ad8eaf8a21b010d (patch)
treec34f1dbb569941baa71974a493fdda8f14beed6a /contrib/guix/manifest.scm
parent5800c558eb5efb4839ed00d6967e43306d68e1c3 (diff)
downloadbitcoin-d3cbff16c2734f310ccc532a4ad8eaf8a21b010d.tar.xz
guix: update signapple
Which includes https://github.com/achow101/signapple/pull/13. We can drop macholib (and altgraph) as deps.
Diffstat (limited to 'contrib/guix/manifest.scm')
-rw-r--r--contrib/guix/manifest.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/contrib/guix/manifest.scm b/contrib/guix/manifest.scm
index ceb178155d..c85ef18ad8 100644
--- a/contrib/guix/manifest.scm
+++ b/contrib/guix/manifest.scm
@@ -422,7 +422,7 @@ and endian independent.")
(license license:expat)))
(define-public python-signapple
- (let ((commit "7a96b4171a360abf0f0f56e499f8f9ed2116280d"))
+ (let ((commit "62155712e7417aba07565c9780a80e452823ae6a"))
(package
(name "python-signapple")
(version (git-version "0.1" "1" commit))
@@ -435,14 +435,13 @@ and endian independent.")
(file-name (git-file-name name commit))
(sha256
(base32
- "0aa4k180jnpal15yhncnm3g3z9gzmi7qb25q5l0kaj444a1p2pm4"))))
+ "1nm6rm4h4m7kbq729si4cm8rzild62mk4ni8xr5zja7l33fhv3gb"))))
(build-system python-build-system)
(propagated-inputs
`(("python-asn1crypto" ,python-asn1crypto)
("python-oscrypto" ,python-oscrypto)
("python-certvalidator" ,python-certvalidator)
- ("python-elfesteem" ,python-elfesteem)
- ("python-macholib" ,python-macholib)))
+ ("python-elfesteem" ,python-elfesteem)))
;; There are no tests, but attempting to run python setup.py test leads to
;; problems, just disable the test
(arguments '(#:tests? #f))