aboutsummaryrefslogtreecommitdiff
path: root/contrib/guix/manifest.scm
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-06-22 10:20:07 +0100
committerfanquake <fanquake@gmail.com>2023-11-28 16:50:04 +0000
commita4980da1ce5e1947fa73ef7057509a26d2c73cfb (patch)
treec2c30452d88d463837a96765f92d81de9a318d81 /contrib/guix/manifest.scm
parent31ce305d46a191621aaa78a73fa4bbc7e58d8ed0 (diff)
downloadbitcoin-a4980da1ce5e1947fa73ef7057509a26d2c73cfb.tar.xz
guix: remove input labels
Migrate package definitions to use the new format for propogated inputs. See https://guix.gnu.org/manual/en/html_node/package-Reference.html#index-inputs_002c-of-packages. See also: https://guix.gnu.org/blog/2021/the-big-change/
Diffstat (limited to 'contrib/guix/manifest.scm')
-rw-r--r--contrib/guix/manifest.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/contrib/guix/manifest.scm b/contrib/guix/manifest.scm
index 8acce55aa3..9206973953 100644
--- a/contrib/guix/manifest.scm
+++ b/contrib/guix/manifest.scm
@@ -80,11 +80,11 @@ FILE-NAME found in ./patches relative to the current file."
(build-system trivial-build-system)
(arguments '(#:builder (begin (mkdir %output) #t)))
(propagated-inputs
- `(("binutils" ,xbinutils)
- ("libc" ,xlibc)
- ("libc:static" ,xlibc "static")
- ("gcc" ,xgcc)
- ("gcc-lib" ,xgcc "lib")))
+ (list xbinutils
+ xlibc
+ xgcc
+ `(,xlibc "static")
+ `(,xgcc "lib")))
(synopsis (string-append "Complete GCC tool chain for " target))
(description (string-append "This package provides a complete GCC tool
chain for " target " development."))
@@ -130,10 +130,10 @@ desirable for building Bitcoin Core release binaries."
(build-system trivial-build-system)
(arguments '(#:builder (begin (mkdir %output) #t)))
(propagated-inputs
- `(("binutils" ,xbinutils)
- ("libc" ,pthreads-xlibc)
- ("gcc" ,pthreads-xgcc)
- ("gcc-lib" ,pthreads-xgcc "lib")))
+ (list xbinutils
+ pthreads-xlibc
+ pthreads-xgcc
+ `(,pthreads-xgcc "lib")))
(synopsis (string-append "Complete GCC tool chain for " target))
(description (string-append "This package provides a complete GCC tool
chain for " target " development."))
@@ -198,8 +198,7 @@ and abstract ELF, PE and MachO formats.")
(base32
"1j47vwq4caxfv0xw68kw5yh00qcpbd56d7rq6c483ma3y7s96yyz"))))
(build-system cmake-build-system)
- (inputs
- `(("openssl", openssl)))
+ (inputs (list openssl))
(home-page "https://github.com/mtrojnar/osslsigncode")
(synopsis "Authenticode signing and timestamping tool")
(description "osslsigncode is a small tool that implements part of the
@@ -256,8 +255,7 @@ thus should be able to compile on most platforms where these exist.")
(files '("etc/ssl/certs/ca-certificates.crt")))))
(propagated-inputs
- `(("python-asn1crypto" ,python-asn1crypto)
- ("openssl" ,openssl)))
+ (list python-asn1crypto openssl))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -295,7 +293,7 @@ thus should be able to compile on most platforms where these exist.")
(package (inherit python-oscrypto)
(name "python-oscryptotests")
(propagated-inputs
- `(("python-oscrypto" ,python-oscrypto)))
+ (list python-oscrypto))
(arguments
`(#:tests? #f
#:phases
@@ -322,9 +320,9 @@ thus should be able to compile on most platforms where these exist.")
"1qw2k7xis53179lpqdqyylbcmp76lj7sagp883wmxg5i7chhc96k"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-asn1crypto" ,python-asn1crypto)
- ("python-oscrypto" ,python-oscrypto)
- ("python-oscryptotests", python-oscryptotests))) ;; certvalidator tests import oscryptotests
+ (list python-asn1crypto
+ python-oscrypto
+ python-oscryptotests)) ;; certvalidator tests import oscryptotests
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -389,10 +387,10 @@ specific moment in time, whitelisting and revocation checks.")
"1nm6rm4h4m7kbq729si4cm8rzild62mk4ni8xr5zja7l33fhv3gb"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-asn1crypto" ,python-asn1crypto)
- ("python-oscrypto" ,python-oscrypto)
- ("python-certvalidator" ,python-certvalidator)
- ("python-elfesteem" ,python-elfesteem)))
+ (list python-asn1crypto
+ python-oscrypto
+ python-certvalidator
+ python-elfesteem))
;; There are no tests, but attempting to run python setup.py test leads to
;; problems, just disable the test
(arguments '(#:tests? #f))