aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcoFalke <*~=`'#}+{/-|&$^_@721217.xyz>2023-07-19 13:34:51 +0200
committerMarcoFalke <*~=`'#}+{/-|&$^_@721217.xyz>2023-09-12 13:41:19 +0200
commitfabb419a3caafc00fbbc533fee14fab7a5d2a2c6 (patch)
treef339c63c7cd7cb336458211bf2030bc7beb48501 /configure.ac
parentfd69ffbbfb3e08b474b33540e56cf4f81e5c21d4 (diff)
downloadbitcoin-fabb419a3caafc00fbbc533fee14fab7a5d2a2c6.tar.xz
doc: Clarify that -fstack-reuse=all bugs exist on all versions of GCC
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index fb154e0b43..449d4f9ed1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -941,9 +941,8 @@ if test "$TARGET_OS" != "windows"; then
AX_CHECK_COMPILE_FLAG([-fPIC], [PIC_FLAGS="-fPIC"])
fi
-dnl Versions of gcc prior to 12.1 (commit
-dnl https://github.com/gcc-mirror/gcc/commit/551aa75778a4c5165d9533cd447c8fc822f583e1)
-dnl are subject to a bug, see the gccbug_90348 test case and
+dnl Currently all versions of gcc are subject to a class of bugs, see the
+dnl gccbug_90348 test case (only reproduces on GCC 11 and earlier) and the related bugs of
dnl https://gcc.gnu.org/bugzilla/show_bug.cgi?id=90348. To work around that, set
dnl -fstack-reuse=none for all gcc builds. (Only gcc understands this flag)
AX_CHECK_COMPILE_FLAG([-fstack-reuse=none], [HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -fstack-reuse=none"])