aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcoFalke <*~=`'#}+{/-|&$^_@721217.xyz>2023-02-08 12:57:12 +0100
committerMarcoFalke <*~=`'#}+{/-|&$^_@721217.xyz>2023-02-08 13:06:11 +0100
commitfa83005a2618abc18f9cd6af96f19fc28aba68d8 (patch)
tree478c3fb50d8197920310b4245cb0b37124d221d2 /configure.ac
parentde1d1895346ed27f471386011d7ff64508f8b39c (diff)
downloadbitcoin-fa83005a2618abc18f9cd6af96f19fc28aba68d8.tar.xz
doc: Document affected gcc versions for -fstack-reuse=none workaround
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index aa1a45c527..2bbcfc0ffe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -935,7 +935,9 @@ if test "$TARGET_OS" != "windows"; then
AX_CHECK_COMPILE_FLAG([-fPIC], [PIC_FLAGS="-fPIC"])
fi
-dnl All versions of gcc that we commonly use for building are subject to bug
+dnl Versions of gcc prior to 12.1 (commit
+dnl https://github.com/gcc-mirror/gcc/commit/551aa75778a4c5165d9533cd447c8fc822f583e1)
+dnl are subject to a bug, see the gccbug_90348 test case and
dnl https://gcc.gnu.org/bugzilla/show_bug.cgi?id=90348. To work around that, set
dnl -fstack-reuse=none for all gcc builds. (Only gcc understands this flag)
AX_CHECK_COMPILE_FLAG([-fstack-reuse=none], [HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -fstack-reuse=none"])