aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcoFalke <*~=`'#}+{/-|&$^_@721217.xyz>2023-08-27 10:45:39 +0200
committerMarcoFalke <*~=`'#}+{/-|&$^_@721217.xyz>2023-12-07 11:05:33 +0100
commitfa67f096bdea9db59dd20c470c9e32f3dac5be94 (patch)
treef01189bd2cfbafa8a93485034613256b0e8d7655 /configure.ac
parentdce1dfbc47050404bcf3ce2461e8baff0b088ffb (diff)
downloadbitcoin-fa67f096bdea9db59dd20c470c9e32f3dac5be94.tar.xz
build: Require C++20 compiler
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 1b5dc32b04..9b39159a32 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,18 +96,8 @@ case $host in
;;
esac
-AC_ARG_ENABLE([c++20],
- [AS_HELP_STRING([--enable-c++20],
- [enable compilation in c++20 mode (disabled by default)])],
- [use_cxx20=$enableval],
- [use_cxx20=no])
-
-dnl Require C++17 compiler (no GNU extensions)
-if test "$use_cxx20" = "no"; then
-AX_CXX_COMPILE_STDCXX([17], [noext], [mandatory])
-else
+dnl Require C++20 compiler (no GNU extensions)
AX_CXX_COMPILE_STDCXX([20], [noext], [mandatory])
-fi
dnl Unless the user specified OBJCXX, force it to be the same as CXX. This ensures
dnl that we get the same -std flags for both.