aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-12-13 21:25:05 +0800
committerfanquake <fanquake@gmail.com>2021-12-13 21:25:05 +0800
commite9440aeb5cad98fea9971f5126461e0a2b30ab54 (patch)
treee63fba7926c6bbf837498b79d7fe941a515d10b9 /configure.ac
parentbf66e258a84e18935fde3ebb9a4b0392bf883222 (diff)
downloadbitcoin-e9440aeb5cad98fea9971f5126461e0a2b30ab54.tar.xz
build: use __SIZEOF_INT128__ for checking __int128 availability
We already use this in the blockfilter code, so not sure we need to maintain two different ways of testing for the same functionality. Consolidate on testing for __SIZEOF_INT128__, which we already use, is supported by the compilers we care about, and is also used by libsecp256k1.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 45def0908b..da71ee93c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -837,9 +837,6 @@ if test "$use_lcov_branch" != "no"; then
AC_SUBST(LCOV_OPTS, "$LCOV_OPTS --rc lcov_branch_coverage=1")
fi
-dnl Check for __int128
-AC_CHECK_TYPES([__int128])
-
dnl Check for endianness
AC_C_BIGENDIAN