aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2024-06-05 21:03:32 +0000
committerCory Fields <cory-nospam-@coryfields.com>2024-06-05 21:06:44 +0000
commitc3a5e8a0639ff2505adb4a4e7776db87d5ebafd3 (patch)
tree4b6e77c738dfa22a635d83cca849e92f63e3257e /configure.ac
parentff7d2054c4f1d7ff98078b9695e7c36e79a476c6 (diff)
downloadbitcoin-c3a5e8a0639ff2505adb4a4e7776db87d5ebafd3.tar.xz
build: re-enable deprecated warning copy
This was disabled in #18738 due to the combo of old gcc and qt, neither of which are relevant to us anymore.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 04c7ecabf7..a1d9e418f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -417,9 +417,6 @@ dnl unknown options if any other warning is produced. Test the -Wfoo case, and
dnl set the -Wno-foo case if it works.
AX_CHECK_COMPILE_FLAG([-Wunused-parameter], [NOWARN_CXXFLAGS="$NOWARN_CXXFLAGS -Wno-unused-parameter"], [], [$CXXFLAG_WERROR])
AX_CHECK_COMPILE_FLAG([-Wself-assign], [NOWARN_CXXFLAGS="$NOWARN_CXXFLAGS -Wno-self-assign"], [], [$CXXFLAG_WERROR])
-if test "$suppress_external_warnings" != "yes" ; then
- AX_CHECK_COMPILE_FLAG([-Wdeprecated-copy], [NOWARN_CXXFLAGS="$NOWARN_CXXFLAGS -Wno-deprecated-copy"], [], [$CXXFLAG_WERROR])
-fi
dnl Don't allow extended (non-ASCII) symbols in identifiers. This is easier for code review.
AX_CHECK_COMPILE_FLAG([-fno-extended-identifiers], [CORE_CXXFLAGS="$CORE_CXXFLAGS -fno-extended-identifiers"], [], [$CXXFLAG_WERROR])