aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2024-02-26 19:52:14 +0000
committerCory Fields <cory-nospam-@coryfields.com>2024-02-27 19:03:26 +0000
commitad7584d8b60119ca3717117a1eb6a16d753c5d74 (patch)
treecf179d06ee94954e70553b7b840db222838c3cd9 /configure.ac
parent4d7d7fd123113342f09871b1a383cda1bb53d0ea (diff)
downloadbitcoin-ad7584d8b60119ca3717117a1eb6a16d753c5d74.tar.xz
serialization: replace char-is-int8_t autoconf detection with c++20 concept
This removes the only remaining autoconf macro in our serialization code, so it can now be used trivially and safely out-of-tree.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 50e6870dd9..45c114688b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1174,14 +1174,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>
[ AC_MSG_RESULT([no])]
)
-AC_MSG_CHECKING([for if type char equals int8_t])
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <stdint.h>
- #include <type_traits>]],
- [[ static_assert(std::is_same<int8_t, char>::value, ""); ]])],
- [ AC_MSG_RESULT([yes]); AC_DEFINE([CHAR_EQUALS_INT8], [1], [Define this symbol if type char equals int8_t]) ],
- [ AC_MSG_RESULT([no])]
-)
-
AC_MSG_CHECKING([for fdatasync])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <unistd.h>]],
[[ fdatasync(0); ]])],