aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2023-05-10 22:50:50 +0000
committerCory Fields <cory-nospam-@coryfields.com>2023-06-22 15:28:47 +0000
commit9bc357e205abc78524eae8906e6d231d6eb9f059 (patch)
treecfb3e31bb622733d75218bfbba502192445ea821 /configure.ac
parentfb61bc0c022cc0fff290b94ee4f9cf9f4160efe2 (diff)
downloadbitcoin-9bc357e205abc78524eae8906e6d231d6eb9f059.tar.xz
build: explicitly opt-in to new fixup_chains functionality for darwin
This replaces (but does not collide with) the previous bind_on_load. There is technically no need to opt-in to this functionality as long as >= MacOS 11.0 is being targetted, but it will be helpful to see in the logs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f9fac057d0..f4368053a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1008,6 +1008,7 @@ if test "$TARGET_OS" = "darwin"; then
AX_CHECK_LINK_FLAG([-Wl,-dead_strip], [CORE_LDFLAGS="$CORE_LDFLAGS -Wl,-dead_strip"], [], [$LDFLAG_WERROR])
AX_CHECK_LINK_FLAG([-Wl,-dead_strip_dylibs], [CORE_LDFLAGS="$CORE_LDFLAGS -Wl,-dead_strip_dylibs"], [], [$LDFLAG_WERROR])
AX_CHECK_LINK_FLAG([-Wl,-bind_at_load], [HARDENED_LDFLAGS="$HARDENED_LDFLAGS -Wl,-bind_at_load"], [], [$LDFLAG_WERROR])
+ AX_CHECK_LINK_FLAG([-Wl,-fixup_chains], [HARDENED_LDFLAGS="$HARDENED_LDFLAGS -Wl,-fixup_chains"], [], [$LDFLAG_WERROR])
fi
AC_CHECK_HEADERS([endian.h sys/endian.h byteswap.h sys/select.h sys/prctl.h sys/sysctl.h vm/vm_param.h sys/vmmeter.h sys/resources.h])