aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-01-07 11:32:51 +0000
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-01-07 11:32:51 +0000
commit8decc5c726caca2381cffbd1b3585862421f5b8e (patch)
treef29e8a018ca05ed03ad50fe25863df83b07d94fd /configure.ac
parent82ba0f80a0b56bb160c8be1fddd82dbbc4fb3947 (diff)
downloadbitcoin-8decc5c726caca2381cffbd1b3585862421f5b8e.tar.xz
build: Fix `-Xclang -internal-isystem` option
LLVM Clang >=16.0 and Apple Clang >=15.0 do not recognize `-Xclang -internal-isystem/usr/local/include` anymore. For example, see: https://github.com/llvm/llvm-project/commit/cbbe1d44546db52c71c9a2b18f85b87ae82df9e7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7b286df603..bcff6c79f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -740,7 +740,7 @@ case $host in
dnl option to system-ify all /usr/local/include paths without adding it to the list
dnl of search paths in case it's not already there.
if test "$suppress_external_warnings" != "no"; then
- AX_CHECK_PREPROC_FLAG([-Xclang -internal-isystem/usr/local/include], [CORE_CPPFLAGS="$CORE_CPPFLAGS -Xclang -internal-isystem/usr/local/include"], [], [$CXXFLAG_WERROR])
+ AX_CHECK_PREPROC_FLAG([-Xclang -internal-isystem -Xclang /usr/local/include/], [CORE_CPPFLAGS="$CORE_CPPFLAGS -Xclang -internal-isystem -Xclang /usr/local/include/"], [], [$CXXFLAG_WERROR])
fi
if test "$use_bdb" != "no" && $BREW list --versions berkeley-db@4 >/dev/null && test "$BDB_CFLAGS" = "" && test "$BDB_LIBS" = ""; then