aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-01-13 15:56:08 +0000
committerfanquake <fanquake@gmail.com>2023-01-13 15:56:16 +0000
commit8915e4d9f5b7e360f70d2f67baa99cca451a10da (patch)
tree94b1d71a807be56569350d1766e9bd4b10f169b7 /configure.ac
parent32834034a3a6bfe2687feb86145d46e610c6ca9d (diff)
parent0f883df7a5430d6b229a2f190fe7daab24802ebf (diff)
downloadbitcoin-8915e4d9f5b7e360f70d2f67baa99cca451a10da.tar.xz
Merge bitcoin/bitcoin#26824: build: fix configuring with only bitcoin-util
0f883df7a5430d6b229a2f190fe7daab24802ebf build: fix configuring with only bitcoin-util (fanquake) Pull request description: Fixes the issue presented in #25037 in a single (easily backportable) diff, with no additional refactoring/changes. Can be tested with: ```bash ./configure \ --disable-tests \ --disable-bench \ --without-libs \ --without-daemon \ --without-gui \ --disable-fuzz-binary \ --without-utils \ --enable-util-util ``` ACKs for top commit: TheCharlatan: tACK 0f883df7a5430d6b229a2f190fe7daab24802ebf hebasto: ACK 0f883df7a5430d6b229a2f190fe7daab24802ebf, tested on Ubuntu 22.04. Tree-SHA512: 3682712405c360852c4edd90c171e21302154bf8789252c64083974a5c873cf04d97e8721c7916d5b2dafa6acd2b8dc32deecf550e90e03bcbbabbbbf75ce959
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fa31e3adbb..a5d9086603 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1461,7 +1461,7 @@ if test "$use_natpmp" != "no"; then
CPPFLAGS="$TEMP_CPPFLAGS"
fi
-if test "$build_bitcoin_wallet$build_bitcoin_cli$build_bitcoin_tx$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench" = "nonononononono"; then
+if test "$build_bitcoin_wallet$build_bitcoin_cli$build_bitcoin_tx$build_bitcoin_util$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench" = "nononononononono"; then
use_boost=no
else
use_boost=yes
@@ -1870,7 +1870,7 @@ else
AC_MSG_RESULT([no])
fi
-if test "$build_bitcoin_wallet$build_bitcoin_cli$build_bitcoin_tx$build_bitcoin_libs$build_bitcoind$bitcoin_enable_qt$enable_fuzz_binary$use_bench$use_tests" = "nonononononononono"; then
+if test "$build_bitcoin_wallet$build_bitcoin_cli$build_bitcoin_tx$build_bitcoin_util$build_bitcoin_libs$build_bitcoind$bitcoin_enable_qt$enable_fuzz_binary$use_bench$use_tests" = "nononononononononono"; then
AC_MSG_ERROR([No targets! Please specify at least one of: --with-utils --with-libs --with-daemon --with-gui --enable-fuzz(-binary) --enable-bench or --enable-tests])
fi