aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2024-02-28 21:41:22 +0000
committerfanquake <fanquake@gmail.com>2024-02-28 21:43:45 +0000
commit7859f4e4b9949912e01bca11aef76d7c1c0452fb (patch)
treec7e46b539ea12b8c737f388f0430ffb80059202a /configure.ac
parentba907f96ad37c09c49c0e1532fad118fcb8dd4a8 (diff)
parentb052b2d1f2b220582a933eb5fa6a28144bed07d8 (diff)
downloadbitcoin-7859f4e4b9949912e01bca11aef76d7c1c0452fb.tar.xz
Merge bitcoin/bitcoin#29486: build: remove -Wdocumentation conditional
b052b2d1f2b220582a933eb5fa6a28144bed07d8 build: remove -Wdocumentation conditional (fanquake) Pull request description: Now that `--enable-suppress-external-warnings` is on by default, we can drop it. CIs are all already building with this flag. ACKs for top commit: Empact: Code review ACK https://github.com/bitcoin/bitcoin/pull/29486/commits/b052b2d1f2b220582a933eb5fa6a28144bed07d8 theuni: utACK b052b2d1f2b220582a933eb5fa6a28144bed07d8 Tree-SHA512: 8b55f366dfeece082090fb87de67d8811967f4c89987a346431b2deb73c3c94401b59ec98bb1cbf790e18894f3d4c4aebb57cbc5fbf931c1046bf40239bc7a58
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 50e6870dd9..4a7c02c1e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -432,10 +432,7 @@ if test "$CXXFLAGS_overridden" = "no"; then
AX_CHECK_COMPILE_FLAG([-Wsuggest-override], [WARN_CXXFLAGS="$WARN_CXXFLAGS -Wsuggest-override"], [], [$CXXFLAG_WERROR])
AX_CHECK_COMPILE_FLAG([-Wimplicit-fallthrough], [WARN_CXXFLAGS="$WARN_CXXFLAGS -Wimplicit-fallthrough"], [], [$CXXFLAG_WERROR])
AX_CHECK_COMPILE_FLAG([-Wunreachable-code], [WARN_CXXFLAGS="$WARN_CXXFLAGS -Wunreachable-code"], [], [$CXXFLAG_WERROR])
-
- if test "$suppress_external_warnings" != "no" ; then
- AX_CHECK_COMPILE_FLAG([-Wdocumentation], [WARN_CXXFLAGS="$WARN_CXXFLAGS -Wdocumentation"], [], [$CXXFLAG_WERROR])
- fi
+ AX_CHECK_COMPILE_FLAG([-Wdocumentation], [WARN_CXXFLAGS="$WARN_CXXFLAGS -Wdocumentation"], [], [$CXXFLAG_WERROR])
dnl Some compilers (gcc) ignore unknown -Wno-* options, but warn about all
dnl unknown options if any other warning is produced. Test the -Wfoo case, and