aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-05-03 10:28:01 +0100
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-05-06 11:29:14 +0100
commit5deb0b024e14c7c63d405c651d1ca323560a1c21 (patch)
tree649bdd3d163fe5e2fe4a6147ed3343dbdba6735f /configure.ac
parent00ac1b963d08f2779d2197edcdb1e76392993378 (diff)
downloadbitcoin-5deb0b024e14c7c63d405c651d1ca323560a1c21.tar.xz
build, test, doc: Temporarily remove Android-related stuff
Previously, our Android builds were geared towards generating APKs, which relied on Qt. However, after migrating to C++20, compiling for Android became unfeasible due to Qt 5.15's compatibility limitations with NDK only up to r25, which includes an outdated embedded libc++. All removed stuff will be reinstated after migrating the build system to CMake and upgrading Qt to version 6.x."
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index ee4400f21a..c0ab6a2fd4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -778,22 +778,6 @@ case $host in
dnl "'NSUserNotificationCenter' is deprecated: first deprecated in macOS 11.0".
OBJCXXFLAGS="$CXXFLAGS -Wno-deprecated-declarations"
;;
- *android*)
- dnl make sure android stays above linux for hosts like *linux-android*
- TARGET_OS=android
- case $host in
- *x86_64*)
- ANDROID_ARCH=x86_64
- ;;
- *aarch64*)
- ANDROID_ARCH=arm64-v8a
- ;;
- *armv7a*)
- ANDROID_ARCH=armeabi-v7a
- ;;
- *) AC_MSG_ERROR([Could not determine Android arch, or it is unsupported]) ;;
- esac
- ;;
*linux*)
TARGET_OS=linux
;;
@@ -1789,7 +1773,6 @@ AC_SUBST(HAVE_O_CLOEXEC)
AC_SUBST(HAVE_BUILTIN_PREFETCH)
AC_SUBST(HAVE_MM_PREFETCH)
AC_SUBST(HAVE_STRONG_GETAUXVAL)
-AC_SUBST(ANDROID_ARCH)
AC_SUBST(HAVE_EVHTTP_CONNECTION_GET_PEER_CONST_CHAR)
AC_CONFIG_FILES([Makefile src/Makefile doc/man/Makefile share/setup.nsi share/qt/Info.plist test/config.ini])
AC_CONFIG_FILES([contrib/devtools/split-debug.sh],[chmod +x contrib/devtools/split-debug.sh])