aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-05-14 17:04:37 +0100
committerfanquake <fanquake@gmail.com>2024-05-21 10:27:42 +0100
commit5bba43312c0ceccfe18bd4d086e12ec0497ed926 (patch)
tree59d5aa8fc5f3a87c8b1fa7b954a4028552879d13 /configure.ac
parenta786fd2041913d82ca90b561de309421bd24e41b (diff)
downloadbitcoin-5bba43312c0ceccfe18bd4d086e12ec0497ed926.tar.xz
build: Enable `thread_local` for MinGW-w64 builds
The assumption in the commit 188ca75e5fe4837d16241446558c7566912f67b2 about the broken `thread_local` implementation in GCC was misguided because the initial failure was not due to GCC, but a bug in the Wine runtime, as evidenced, for example, here: - https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=917307 - https://bugs.freedesktop.org/show_bug.cgi?id=108662 Consequently, it is safe to re-enable `thread_local` support for MinGW-w64 builds.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index bfc1e54921..b80466b13e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1043,12 +1043,6 @@ if test "$use_thread_local" = "yes" || test "$use_thread_local" = "auto"; then
])],
[
case $host in
- *mingw*)
- dnl mingw32's implementation of thread_local has also been shown to behave
- dnl erroneously under concurrent usage; see:
- dnl https://gist.github.com/jamesob/fe9a872051a88b2025b1aa37bfa98605
- AC_MSG_RESULT([no])
- ;;
*)
AC_DEFINE([HAVE_THREAD_LOCAL], [1], [Define if thread_local is supported.])
AC_MSG_RESULT([yes])