aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2022-03-22 14:13:13 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2022-03-22 14:13:13 +0000
commit5a157eb3703e1e65ed285f13a824562ab12aa3ff (patch)
tree25a61cfc82ad08f47f5136f9880ee4cb68ccac22 /configure.ac
parent556ee6f2fa0e2da2bb12fe05a885431f61db2e47 (diff)
downloadbitcoin-5a157eb3703e1e65ed285f13a824562ab12aa3ff.tar.xz
Bugfix: configure: Only avoid -isystem for exact /usr/include path
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index db283347cd..430ed75e07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1175,7 +1175,7 @@ dnl Do not change "-I/usr/include" to "-isystem /usr/include" because that
dnl is not necessary (/usr/include is already a system directory) and because
dnl it would break GCC's #include_next.
AC_DEFUN([SUPPRESS_WARNINGS],
- [[$(echo $1 |${SED} -E -e 's/(^| )-I/\1-isystem /g' -e 's;-isystem /usr/include([/ ]|$);-I/usr/include\1;g')]])
+ [[$(echo $1 |${SED} -E -e 's/(^| )-I/\1-isystem /g' -e 's;-isystem /usr/include/*( |$);-I/usr/include\1;g')]])
dnl enable-fuzz should disable all other targets
if test "x$enable_fuzz" = "xyes"; then