aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorwillcl-ark <will@256k1.dev>2023-05-22 10:46:36 +0100
committerwillcl-ark <will@256k1.dev>2023-05-23 13:44:07 +0100
commit59c89447499bd9d6202269879555b8bc37373aa2 (patch)
tree448fb64a1f5f4c67c4a028de9385194710be1d47 /configure.ac
parent22139f6e83a2bedd2dad9f280567d2c76c54252f (diff)
downloadbitcoin-59c89447499bd9d6202269879555b8bc37373aa2.tar.xz
build: disable boost multi index safe mode
Disable boost multi index safe mode by default when configuring with --enable-debug. This option can cause transactions to take a long time to be accepted into the mempool under certain conditions; iterator destruction takes O(n) time vs O(1) as they are stored in a singly linked list. See 27586 for more information. Re-enable it on the CI builds which previously had it enabled. Re-enable it on the msan fuzz target so that we have fuzz tasks testing with it enabeld and disabled in this repo.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 0 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index fc692c4f6a..8015813ec7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1491,10 +1491,6 @@ if test "$use_boost" = "yes"; then
AX_CHECK_PREPROC_FLAG([-DBOOST_NO_CXX98_FUNCTION_BASE], [BOOST_CPPFLAGS="$BOOST_CPPFLAGS -DBOOST_NO_CXX98_FUNCTION_BASE"], [], [$CXXFLAG_WERROR],
[AC_LANG_PROGRAM([[#include <boost/config.hpp>]])])
- if test "$enable_debug" = "yes" || test "$enable_fuzz" = "yes"; then
- BOOST_CPPFLAGS="$BOOST_CPPFLAGS -DBOOST_MULTI_INDEX_ENABLE_SAFE_MODE"
- fi
-
if test "$suppress_external_warnings" != "no"; then
BOOST_CPPFLAGS=SUPPRESS_WARNINGS($BOOST_CPPFLAGS)
fi