aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2022-09-20 11:26:01 +0100
committerfanquake <fanquake@gmail.com>2022-09-21 16:53:18 +0100
commit55aad5f3a957296776cfd8d7a4a251361355b8e8 (patch)
tree9eea637cdfe4fe6742200414c5c183abfbc08dde /configure.ac
parentb95633121bf32587fb24d22e5f26ddffb51cd7f7 (diff)
downloadbitcoin-55aad5f3a957296776cfd8d7a4a251361355b8e8.tar.xz
build: remove stdio.h from header checks
We already use a mix of <cstdio> and stdio.h unconditionally throughout the codebase. Us checking this header also duplicates work already done by autotools. Currently stdio.h is checked for 3 times during a ./configure run, after this change, at least it's only twice.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3791385a66..5b1ce4ed7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1010,7 +1010,7 @@ if test "$TARGET_OS" = "darwin"; then
AX_CHECK_LINK_FLAG([-Wl,-bind_at_load], [HARDENED_LDFLAGS="$HARDENED_LDFLAGS -Wl,-bind_at_load"], [], [$LDFLAG_WERROR])
fi
-AC_CHECK_HEADERS([endian.h sys/endian.h byteswap.h stdio.h stdlib.h unistd.h sys/types.h sys/stat.h sys/select.h sys/prctl.h sys/sysctl.h vm/vm_param.h sys/vmmeter.h sys/resources.h])
+AC_CHECK_HEADERS([endian.h sys/endian.h byteswap.h stdlib.h unistd.h sys/types.h sys/stat.h sys/select.h sys/prctl.h sys/sysctl.h vm/vm_param.h sys/vmmeter.h sys/resources.h])
AC_CHECK_DECLS([getifaddrs, freeifaddrs],[CHECK_SOCKET],,
[#include <sys/types.h>