aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2022-09-23 10:49:33 +0100
committerfanquake <fanquake@gmail.com>2022-09-23 10:49:33 +0100
commit553ff452c0e95a9647d35f10f67e45f24bd2d9b7 (patch)
tree54db6e943d61c688720cec791d0442d58d89cd83 /configure.ac
parenta63d4cb26a2830b297288aa6acf5b69108353334 (diff)
downloadbitcoin-553ff452c0e95a9647d35f10f67e45f24bd2d9b7.tar.xz
build: remove stdlib.h from header checks
We already use a mix of <cstdlib> and stdlib.h unconditionally throughout the codebase. Us checking this header also duplicates work already done by autotools. Currently stdlib.h is checked for 3 times during a ./configure run, after this change, at least it's only twice.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5b1ce4ed7e..82cb469864 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1010,7 +1010,7 @@ if test "$TARGET_OS" = "darwin"; then
AX_CHECK_LINK_FLAG([-Wl,-bind_at_load], [HARDENED_LDFLAGS="$HARDENED_LDFLAGS -Wl,-bind_at_load"], [], [$LDFLAG_WERROR])
fi
-AC_CHECK_HEADERS([endian.h sys/endian.h byteswap.h stdlib.h unistd.h sys/types.h sys/stat.h sys/select.h sys/prctl.h sys/sysctl.h vm/vm_param.h sys/vmmeter.h sys/resources.h])
+AC_CHECK_HEADERS([endian.h sys/endian.h byteswap.h unistd.h sys/types.h sys/stat.h sys/select.h sys/prctl.h sys/sysctl.h vm/vm_param.h sys/vmmeter.h sys/resources.h])
AC_CHECK_DECLS([getifaddrs, freeifaddrs],[CHECK_SOCKET],,
[#include <sys/types.h>