aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormerge-script <fanquake@gmail.com>2024-05-21 21:14:30 +0100
committermerge-script <fanquake@gmail.com>2024-05-21 21:14:30 +0100
commit2ec0a28a37dbb50d463899f53c28fb96905d97b7 (patch)
tree3cf8f4444d394df3e771d88a6ea97fd7d04f0cec /configure.ac
parent6c13b1375f8fd810f46f5650e01a464ee63cfa46 (diff)
parent17fe948cce2eb75f0f3f4b0db9d0d90648c7d4af (diff)
downloadbitcoin-2ec0a28a37dbb50d463899f53c28fb96905d97b7.tar.xz
Merge bitcoin/bitcoin#30137: build: Remove `--enable-threadlocal`
17fe948cce2eb75f0f3f4b0db9d0d90648c7d4af build: remove --enable-threadlocal (fanquake) 1e7c20bc19a216269c646177ab90cfa084c096a5 doc: remove comment about using thread_local (fanquake) 5bba43312c0ceccfe18bd4d086e12ec0497ed926 build: Enable `thread_local` for MinGW-w64 builds (Hennadii Stepanov) Pull request description: Includes a commit from #30099. Closes #29952. ACKs for top commit: laanwj: Code review ACK 17fe948cce2eb75f0f3f4b0db9d0d90648c7d4af maflcko: utACK 17fe948cce2eb75f0f3f4b0db9d0d90648c7d4af hebasto: ACK 17fe948cce2eb75f0f3f4b0db9d0d90648c7d4af. theuni: utACK 17fe948cce2eb75f0f3f4b0db9d0d90648c7d4af Tree-SHA512: 2aad6d19e79c4d6d7aefd0f41b215ac8d9320f5908808221d78e6ee1c77503832a02759bee2ad397e235b6739e22aca8dcf5c5ef8854deb8c697b18ac56a06da
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 0 insertions, 40 deletions
diff --git a/configure.ac b/configure.ac
index bfc1e54921..d539e4436f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -244,12 +244,6 @@ AC_ARG_ENABLE([lcov-branch-coverage],
[use_lcov_branch=yes],
[use_lcov_branch=no])
-AC_ARG_ENABLE([threadlocal],
- [AS_HELP_STRING([--enable-threadlocal],
- [enable features that depend on the c++ thread_local keyword (currently just thread names in debug logs). (default is to enable if there is platform support)])],
- [use_thread_local=$enableval],
- [use_thread_local=auto])
-
AC_ARG_ENABLE([zmq],
[AS_HELP_STRING([--disable-zmq],
[disable ZMQ notifications])],
@@ -1028,40 +1022,6 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
[AC_MSG_RESULT([no])]
)
-if test "$use_thread_local" = "yes" || test "$use_thread_local" = "auto"; then
- TEMP_LDFLAGS="$LDFLAGS"
- LDFLAGS="$TEMP_LDFLAGS $PTHREAD_CFLAGS"
- AC_MSG_CHECKING([for thread_local support])
- AC_LINK_IFELSE([AC_LANG_SOURCE([
- #include <thread>
- static thread_local int foo = 0;
- static void run_thread() { foo++;}
- int main(){
- for(int i = 0; i < 10; i++) { std::thread(run_thread).detach();}
- return foo;
- }
- ])],
- [
- case $host in
- *mingw*)
- dnl mingw32's implementation of thread_local has also been shown to behave
- dnl erroneously under concurrent usage; see:
- dnl https://gist.github.com/jamesob/fe9a872051a88b2025b1aa37bfa98605
- AC_MSG_RESULT([no])
- ;;
- *)
- AC_DEFINE([HAVE_THREAD_LOCAL], [1], [Define if thread_local is supported.])
- AC_MSG_RESULT([yes])
- ;;
- esac
- ],
- [
- AC_MSG_RESULT([no])
- ]
- )
- LDFLAGS="$TEMP_LDFLAGS"
-fi
-
dnl Check for different ways of gathering OS randomness
AC_MSG_CHECKING([for Linux getrandom function])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[