aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-01-13 15:35:57 +0000
committerfanquake <fanquake@gmail.com>2023-01-28 15:26:12 +0000
commit02f5a5e7b5fd7ba35e407d4409202a0e0fed003c (patch)
tree7d83306e921c5e944761d21e7aa0fa1887ede392 /configure.ac
parent25a0e8ba0b31d8bd265df0589fe49241a60d0fc2 (diff)
downloadbitcoin-02f5a5e7b5fd7ba35e407d4409202a0e0fed003c.tar.xz
build: remove --enable-natpmp-default from configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 1 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 2638742232..41c12c0a00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,12 +175,6 @@ AC_ARG_WITH([natpmp],
[use_natpmp=$withval],
[use_natpmp=auto])
-AC_ARG_ENABLE([natpmp-default],
- [AS_HELP_STRING([--enable-natpmp-default],
- [if NAT-PMP is enabled, turn it on at startup (default is no)])],
- [use_natpmp_default=$enableval],
- [use_natpmp_default=no])
-
AC_ARG_ENABLE(tests,
AS_HELP_STRING([--disable-tests],[do not compile tests (default is to compile)]),
[use_tests=$enableval],
@@ -1793,15 +1787,8 @@ if test "$have_natpmp" = "no"; then
else
if test "$use_natpmp" != "no"; then
AC_MSG_RESULT([yes])
- AC_MSG_CHECKING([whether to build with NAT-PMP enabled by default])
use_natpmp=yes
- natpmp_setting=0
- if test "$use_natpmp_default" != "no"; then
- use_natpmp_default=yes
- natpmp_setting=1
- fi
- AC_MSG_RESULT($use_natpmp_default)
- AC_DEFINE_UNQUOTED([USE_NATPMP], [$natpmp_setting], [NAT-PMP support not compiled if undefined, otherwise value (0 or 1) determines default state])
+ AC_DEFINE([USE_NATPMP], [1], [Define to 1 if UPnP support should be compiled in.])
if test "$TARGET_OS" = "windows"; then
NATPMP_CPPFLAGS="$NATPMP_CPPFLAGS -DSTATICLIB -DNATPMP_STATICLIB"
fi