aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2024-01-10 13:54:44 +0000
committerfanquake <fanquake@gmail.com>2024-01-16 09:51:19 +0000
commit00c1e2aa4496b5f038ae5199dbd16d8313766533 (patch)
tree2436529f7d59510be80cce98bd93845348d1175a /configure.ac
parent1dc2c9b385f8345c588449848149b8e470653afc (diff)
downloadbitcoin-00c1e2aa4496b5f038ae5199dbd16d8313766533.tar.xz
build: fix optimisation flags used for --coverage
-O0 is just overriding -Og.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2173f78bc3..951dbdbf83 100644
--- a/configure.ac
+++ b/configure.ac
@@ -862,7 +862,7 @@ if test "$use_lcov" = "yes"; then
[AC_MSG_ERROR([lcov testing requested but --coverage linker flag does not work])])
AX_CHECK_COMPILE_FLAG([--coverage],[CORE_CXXFLAGS="$CORE_CXXFLAGS --coverage"],
[AC_MSG_ERROR([lcov testing requested but --coverage flag does not work])])
- CORE_CXXFLAGS="$CORE_CXXFLAGS -Og -O0"
+ CORE_CXXFLAGS="$CORE_CXXFLAGS -Og"
fi
if test "$use_lcov_branch" != "no"; then