aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-09-06 22:07:31 +0100
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-09-06 22:07:31 +0100
commitfdad128b528bc8622bc6d8343026c28b18260f64 (patch)
tree95f1073517ce23544238be85f8b53accfa8893ac /CMakeLists.txt
parentb2a6f545b4f6e3442ae51f66a6f3c1de92d00a1b (diff)
downloadbitcoin-fdad128b528bc8622bc6d8343026c28b18260f64.tar.xz
build: Stop enabling CMake's CMP0141 policy
The `CMAKE_MSVC_DEBUG_INFORMATION_FORMAT` variable has not been used since the merge of https://github.com/hebasto/bitcoin/pull/215 in the CMake staging branch.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3aba137d09..c636b3bf3f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,12 +8,6 @@
# Centos Stream 9, https://www.centos.org/cl-vs-cs/#end-of-life, EOL in May 2027:
# - CMake 3.26.5, https://mirror.stream.centos.org/9-stream/AppStream/x86_64/os/Packages/
cmake_minimum_required(VERSION 3.22)
-if(POLICY CMP0141)
- # MSVC debug information format flags are selected by an abstraction.
- # We want to use the CMAKE_MSVC_DEBUG_INFORMATION_FORMAT variable
- # to select the MSVC debug information format.
- cmake_policy(SET CMP0141 NEW)
-endif()
if (${CMAKE_SOURCE_DIR} STREQUAL ${CMAKE_BINARY_DIR})
message(FATAL_ERROR "In-source builds are not allowed.")