aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-06-30 10:13:51 +0100
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-08-16 19:27:36 +0100
commit35cffc497d8db3cf3eee35c1513e3435558f056b (patch)
tree95e0b1c0641796c2b7a626ee3847ecbf9c6206e5 /CMakeLists.txt
parentfd72d00ffe34c84e292b305f6797201040d31a72 (diff)
downloadbitcoin-35cffc497d8db3cf3eee35c1513e3435558f056b.tar.xz
cmake: Add POSIX threads support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f03b5d6505..3a6d73e956 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,6 +85,12 @@ target_link_libraries(core_interface INTERFACE
$<$<CONFIG:Debug>:core_interface_debug>
)
+set(THREADS_PREFER_PTHREAD_FLAG ON)
+find_package(Threads REQUIRED)
+target_link_libraries(core_base_interface INTERFACE
+ Threads::Threads
+)
+
include(cmake/introspection.cmake)
# TODO: The `CMAKE_SKIP_BUILD_RPATH` variable setting can be deleted