aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-08-06 18:16:47 +0100
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-08-16 19:27:36 +0100
commit27d687fc1f6aceaed7725e1e904a093ead68d6e6 (patch)
treeeede9185e49d2a5c3090ca1680788e09836f557e /CMakeLists.txt
parentfe5cdace5ffba46fb7981efb816621962d3873e3 (diff)
downloadbitcoin-27d687fc1f6aceaed7725e1e904a093ead68d6e6.tar.xz
cmake: Add `config/bitcoin-config.h` support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3fed7f60d5..3e60890bcb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,6 +74,16 @@ target_link_libraries(core_interface INTERFACE
$<$<CONFIG:Debug>:core_interface_debug>
)
+# TODO: The `CMAKE_SKIP_BUILD_RPATH` variable setting can be deleted
+# in the future after reordering Guix script commands to
+# perform binary checks after the installation step.
+# Relevant discussions:
+# - https://github.com/hebasto/bitcoin/pull/236#issuecomment-2183120953
+# - https://github.com/bitcoin/bitcoin/pull/30312#issuecomment-2191235833
+set(CMAKE_SKIP_BUILD_RPATH TRUE)
+set(CMAKE_SKIP_INSTALL_RPATH TRUE)
+add_subdirectory(src)
+
message("\n")
message("Configure summary")
message("=================")