aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-06-30 12:40:17 +0100
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-08-16 19:27:40 +0100
commit027c6d7caa0355c35b00f2689eddccc3d1227aef (patch)
treeececd11426bba5476e842beabfcd5c59c6525f5f /CMakeLists.txt
parentd10c5c34c3d899db8bcff47ac8c6ba396a6da4b6 (diff)
downloadbitcoin-027c6d7caa0355c35b00f2689eddccc3d1227aef.tar.xz
cmake: Build `bitcoin-tx` executable
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 406c53a564..71895845bc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,6 +70,7 @@ option(BUILD_DAEMON "Build bitcoind executable." ON)
option(BUILD_CLI "Build bitcoin-cli executable." ON)
option(BUILD_TESTS "Build test_bitcoin executable." ON)
+option(BUILD_TX "Build bitcoin-tx executable." ${BUILD_TESTS})
option(ENABLE_WALLET "Enable wallet." ON)
option(WITH_SQLITE "Enable SQLite wallet support." ${ENABLE_WALLET})
@@ -267,6 +268,7 @@ message("=================")
message("Executables:")
message(" bitcoind ............................ ${BUILD_DAEMON}")
message(" bitcoin-cli ......................... ${BUILD_CLI}")
+message(" bitcoin-tx .......................... ${BUILD_TX}")
message(" bitcoin-wallet ...................... ${BUILD_WALLET_TOOL}")
message("Optional features:")
message(" wallet support ...................... ${ENABLE_WALLET}")