diff options
author | Filippo Valsorda <filippo.valsorda@gmail.com> | 2012-11-29 16:51:55 +0100 |
---|---|---|
committer | Filippo Valsorda <filippo.valsorda@gmail.com> | 2012-11-29 16:51:55 +0100 |
commit | cc51a7d4e030646a5d7075934f11036ad52a3f1f (patch) | |
tree | f3f19a3c81964b5d7d2edbacb0a2bca787fbc0bd /setup.py | |
parent | 8192ebe1f874b22b0c27e675a4136a06e46a68ce (diff) |
New repo skeleton, getting ready for PyPi
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 68 |
1 files changed, 23 insertions, 45 deletions
@@ -1,31 +1,13 @@ -from distutils.core import setup, Command +from distutils.core import setup +import pkg_resources import sys + try: import py2exe except ImportError: - sys.stderr.write("Cannot import py2exe") -import subprocess - -"""The p2exe option will create an exe that needs Microsoft Visual C++ 2008 Redistributable Package. - python setup.py py2exe - You can also build a zip executable with - python setup.py bdist --format=zip - - The test suite can be run with - python setup.py test - - - The actual version is defined by the last git tag -""" + print >> sys.stderr, "Cannot import py2exe" -# If run without args, build executables -#if len(sys.argv) == 1: -# sys.argv.append("py2exe") - -# os.chdir(os.path.dirname(os.path.abspath(sys.argv[0]))) # conflict with wine-py2exe.sh -#sys.path.append('./youtube_dl') - -options = { +py2exe_options = { "bundle_files": 1, "compressed": 1, "optimize": 2, @@ -33,33 +15,29 @@ options = { "dll_excludes": ['w9xpopen.exe'] } -console = [{ +py2exe_console = [{ "script":"./youtube_dl/__main__.py", "dest_base": "youtube-dl", }] -init_file = open('./youtube_dl/__init__.py') +execfile('youtube_dl/version.py') -try: - #return the last tag name - version = subprocess.checkoutput(["git", "describe", "--abbrev=0", "--tags"]) -except: - version = '' +setup( + name = 'youtube_dl', + version = __version__, + description = 'Small command-line program to download videos from YouTube.com and other video sites', + url = 'https://github.com/rg3/youtube-dl', + author = 'Ricardo Garcia', + maintainer = 'Philipp Hagemeister', + maintainer_email = 'phihag@phihag.de', + packages = ['youtube_dl'], -setup(name='youtube-dl', - version=version, - long_description='Small command-line program to download videos from YouTube.com and other video sites', - url='https://github.com/rg3/youtube-dl', - packages=['youtube_dl'], - #test suite - test_suite='nose.collector', - test_requires=['nosetest'], - console=console, - options={"py2exe": options}, - scripts=['bin/youtube-dl'], - zipfile=None, -) + test_suite = 'nose.collector', + test_requires = ['nosetest'], -#import shutil -#shutil.rmtree("build") + console = py2exe_console, + options = { "py2exe": py2exe_options }, + scripts = ['bin/youtube-dl'], + zipfile = None, +) |