diff options
author | David Coppa <dcoppa@gmail.com> | 2013-01-30 15:31:38 +0100 |
---|---|---|
committer | David Coppa <dcoppa@gmail.com> | 2013-01-30 15:31:38 +0100 |
commit | a32b573ccb71de6d50cdb4dcf8e44928c70f92a6 (patch) | |
tree | 65a34838a1b7b7d6ec45e55ecb39aca2ac331f65 /setup.py | |
parent | ec71c13ab891566abff9010710afb915e8f22523 (diff) |
Try setuptools first, then fallback to distutils.core
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -2,11 +2,15 @@ # -*- coding: utf-8 -*- from __future__ import print_function -from distutils.core import setup import pkg_resources import sys try: + from setuptools import setup +except ImportError: + from distutils.core import setup + +try: import py2exe """This will create an exe that needs Microsoft Visual C++ 2008 Redistributable Package""" except ImportError: |