aboutsummaryrefslogtreecommitdiff
path: root/tools/depends/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'tools/depends/configure.ac')
-rw-r--r--tools/depends/configure.ac72
1 files changed, 13 insertions, 59 deletions
diff --git a/tools/depends/configure.ac b/tools/depends/configure.ac
index 3ab992a34e..83389ee165 100644
--- a/tools/depends/configure.ac
+++ b/tools/depends/configure.ac
@@ -7,7 +7,7 @@ AC_CONFIG_FILES([target/config.site native/config.site.native Makefile.include t
AC_CANONICAL_HOST
m4_include([m4/xbmc_arch.m4])
-m4_include([m4/ax_cxx_compile_stdcxx_14.m4])
+m4_include([m4/ax_cxx_compile_stdcxx.m4])
# check for not same cpu value
AC_DEFUN([MC_CHECK_NOT_CPU],
@@ -232,11 +232,6 @@ AC_PATH_TOOL([CC],[$platform_cc],,$PATH_FOR_HOST)
AC_PATH_TOOL([CXX],[$platform_cxx],,$PATH_FOR_HOST)
AC_PROG_CPP
-AX_CXX_COMPILE_STDCXX_14([noext],[mandatory])
-c14_flags=$(echo "$CFLAGS" | sed 's/-O@<:@123@:>@//g;s/-g //g;s/ //g')
-cxx14_flags=$(echo "$CXXFLAGS" | sed 's/-O@<:@123@:>@//g;s/-g //g;s/ //g')
-
-
case $host in
*-*linux-android*)
deps_dir="$use_host-$use_ndk_api-$build_type"
@@ -262,7 +257,7 @@ case $host in
if test "x$use_cpu" = "xarm64-v8a"; then
platform_cflags+=" -march=armv8-a -mtune=cortex-a53"
fi
- meson_cpu="arch64"
+ meson_cpu="aarch64"
;;
i*86*-linux-android*|x86_64*-linux-android*)
if test "x$use_cpu" = "xauto"; then
@@ -397,6 +392,7 @@ case $host in
11.*);;
12.*);;
13.*);;
+ 14.*);;
*)
AC_MSG_ERROR(error in configure of --with-sdk=$use_sdk)
;;
@@ -431,30 +427,6 @@ case $use_platform in
fi
target_platform=$use_platform
;;
- raspberry-pi)
- target_platform=raspberry-pi
- use_cpu=arm1176jzf-s
- ffmpeg_options_default="--cpu=arm1176jzf-s"
- platform_cflags="-mcpu=arm1176jzf-s -mtune=arm1176jzf-s -mfloat-abi=hard -mfpu=vfp"
- platform_cxxflags="-mcpu=arm1176jzf-s -mtune=arm1176jzf-s -mfloat-abi=hard -mfpu=vfp"
- platform_ldflags=""
- ;;
- raspberry-pi2)
- target_platform=raspberry-pi
- use_cpu=cortex-a7
- ffmpeg_options_default="--cpu=cortex-a7"
- platform_cflags="-fPIC -mcpu=cortex-a7 -mfloat-abi=hard -mfpu=neon-vfpv4 -mvectorize-with-neon-quad"
- platform_cxxflags="-fPIC -mcpu=cortex-a7 -mfloat-abi=hard -mfpu=neon-vfpv4 -mvectorize-with-neon-quad"
- platform_ldflags="-lpthread"
- ;;
- raspberry-pi3)
- target_platform=raspberry-pi
- use_cpu=cortex-a53
- ffmpeg_options_default="--cpu=cortex-a53"
- platform_cflags="-fPIC -mcpu=cortex-a53 -mfloat-abi=hard -mfpu=neon-fp-armv8 -mvectorize-with-neon-quad"
- platform_cxxflags="-fPIC -mcpu=cortex-a53 -mfloat-abi=hard -mfpu=neon-fp-armv8 -mvectorize-with-neon-quad"
- platform_ldflags="-lpthread"
- ;;
tvos)
platform_cflags+=" -fembed-bitcode"
platform_cxxflags+=" -fembed-bitcode"
@@ -468,32 +440,6 @@ case $use_platform in
AC_MSG_ERROR(unsupported platform ($use_platform))
esac
-if test "$target_platform" = "raspberry-pi" ; then
- if test -d "${use_firmware}/opt/vc/include"; then
- :
- else
- AC_MSG_ERROR([Raspberry Pi firmware not found])
- fi
- use_arch="arm"
- use_hardcoded_tables="yes"
- ARCH="arm"
- cross_compiling="yes"
- use_host="arm-linux-gnueabihf"
- deps_dir="$use_platform-$build_type"
- platform_cflags+=" -pipe -mabi=aapcs-linux -Wno-psabi \
- -Wa,-mno-warn-deprecated -Wno-deprecated-declarations \
- -isystem${use_firmware}/opt/vc/include \
- -isystem${use_firmware}/opt/vc/include/interface/vcos/pthreads \
- -isystem${use_firmware}/opt/vc/include/interface/vmcs_host/linux"
- platform_cxxflags+=" -pipe -mabi=aapcs-linux -Wno-psabi \
- -Wa,-mno-warn-deprecated -Wno-deprecated-declarations \
- -isystem${use_firmware}/opt/vc/include \
- -isystem${use_firmware}/opt/vc/include/interface/vcos/pthreads \
- -isystem${use_firmware}/opt/vc/include/interface/vmcs_host/linux"
- platform_ldflags+=" -L${use_firmware}/opt/vc/lib -lEGL -lGLESv2 -lbcm_host -lvcos \
- -lvchiq_arm"
-fi
-
XBMC_SETUP_ARCH_DEFINES()
@@ -611,8 +557,8 @@ if [ ! `mkdir -p $use_tarballs` ]; then
fi
# remove unwanted optimization flags
-tmp_cflags=$(echo $c14_flags $platform_cflags | sed 's/-O@<:@123@:>@//g;s/-g //g;s/ \{2,\}//g')
-tmp_cxxflags=$(echo $cxx14_flags $platform_cxxflags | sed 's/-O@<:@123@:>@//g;s/-g //g;s/ \{2,\}//g')
+tmp_cflags=$(echo $CFLAGS $platform_cflags | sed 's/-O@<:@123@:>@//g;s/-g //g;s/ \{2,\}//g')
+tmp_cxxflags=$(echo $CXXFLAGS $platform_cxxflags | sed 's/-O@<:@123@:>@//g;s/-g //g;s/ \{2,\}//g')
release_cflags="-DNDEBUG=1"
@@ -642,6 +588,12 @@ else
platform_cxxflags="$platform_cxxflags_release"
fi
+CXXFLAGS="$platform_cxxflags $platform_includes"
+CXX_CACHED="$CXX"
+AX_CXX_COMPILE_STDCXX([17], [noext], [mandatory])
+CXX="$CXX_CACHED"
+platform_cxxflags+=" -std=c++17"
+
if test "$ffmpeg_options" == "default"; then
ffmpeg_options="$ffmpeg_options_default"
fi
@@ -708,6 +660,8 @@ echo -e "build type:\t $build_type"
echo -e "toolchain:\t $use_toolchain"
echo -e "cpu:\t\t $use_cpu"
echo -e "host:\t\t $use_host"
+echo -e "CC:\t\t $CC"
+echo -e "CXX:\t\t $CXX"
echo -e "cflags:\t\t $platform_cflags"
echo -e "cxxflags:\t $platform_cxxflags"
echo -e "ldflags:\t $platform_ldflags"