aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 808f74bdcf..9b9c36c7cc 100644
--- a/configure.in
+++ b/configure.in
@@ -757,7 +757,7 @@ AC_CHECK_PROG(HAVE_GIT,git,"yes","no",)
if test "$GIT_REV" = ""; then
if test -f VERSION ; then
GIT_REV=$(awk 'END{print substr($1,1,16)}' VERSION)
- elif test "$HAVE_GIT" = "yes"; then
+ elif test "$HAVE_GIT" = "yes" -a -d $(abs_top_srcdir)/.git; then
GIT_REV=$(git --no-pager log --abbrev=7 -n 1 --pretty=format:"%h %ci" HEAD | awk '{gsub("-", "");print $2"-"$1}')
else
GIT_REV="Unknown"