aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 23 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8fcbe86cbe..ec5ea781aa 100644
--- a/configure.in
+++ b/configure.in
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([xbmc], [12.9.8], [http://trac.xbmc.org])
+AC_INIT([xbmc], [12.9.9], [http://trac.xbmc.org])
AC_CONFIG_HEADERS([xbmc/config.h])
AH_TOP([#pragma once])
m4_include([m4/ax_prog_cc_for_build.m4])
@@ -621,9 +621,17 @@ case $host in
;;
i*86*-linux-gnu*)
ARCH="i486-linux"
+ if test "$use_cpu" = "no" -a "$cross_compiling" = "yes"; then
+ use_arch="x86"
+ use_cpu="i686"
+ fi
;;
x86_64-*-linux-gnu*)
ARCH="x86_64-linux"
+ if test "$use_cpu" = "no" -a "$cross_compiling" = "yes"; then
+ use_arch="x86_64"
+ use_cpu="x86_64"
+ fi
;;
i386-*-freebsd*)
ARCH="x86-freebsd"
@@ -914,6 +922,13 @@ if test "x$have_builtin_sync_val_compare_and_swap" = "xyes"; then
[Define to 1 if your compiler supports the __sync_val_compare_and_swap() intrinsic.])
fi
+# Check for u16string/u32string declarations
+AC_LANG_PUSH([C++])
+AC_CHECK_TYPES([std::u16string, std::u32string], [], [], [[#include <string>]])
+AC_CHECK_TYPES([char16_t, char32_t])
+AC_CHECK_SIZEOF([wchar_t])
+AC_LANG_POP([C++])
+
# Add top source directory for all builds so we can use config.h
INCLUDES="-I\$(abs_top_srcdir) $INCLUDES"
@@ -2344,11 +2359,17 @@ else
fi
if test "x$add_players" != "xno"; then
- final_message="$final_message\n additional players:\tYes"
+ final_message="$final_message\n additional players:\tYes, $add_players"
else
final_message="$final_message\n additional players:\tNo"
fi
+if test "x$add_codecs" != "xno"; then
+ final_message="$final_message\n additional codecs:\tYes, $add_codecs"
+else
+ final_message="$final_message\n additional codecs:\tNo"
+fi
+
### External libraries messages
if test "$use_external_ffmpeg" = "yes"; then