aboutsummaryrefslogtreecommitdiff
path: root/tools/depends/configure.ac
diff options
context:
space:
mode:
authorPhilipp Kerling <pkerling@casix.org>2017-08-06 16:59:36 +0200
committerPhilipp Kerling <pkerling@casix.org>2017-09-09 21:46:32 +0300
commitc1d3beedb16ba0cda61919361ba69f4c2c1473c5 (patch)
tree7c04e931394b239419719094dc2c5d3135fc35de /tools/depends/configure.ac
parentee7f71f847c054ecc779261cf05abdb39dcb3f7c (diff)
Remove dependency on (un)zip where unwarranted
zip is only used for darwin codesigning. unzip is used both for codesigning and android. All other platforms do not use them, so no need to check for them.
Diffstat (limited to 'tools/depends/configure.ac')
-rw-r--r--tools/depends/configure.ac24
1 files changed, 14 insertions, 10 deletions
diff --git a/tools/depends/configure.ac b/tools/depends/configure.ac
index 3fb921f8e1..d9a62f7256 100644
--- a/tools/depends/configure.ac
+++ b/tools/depends/configure.ac
@@ -107,16 +107,6 @@ if test "$use_ccache" = "yes"; then
fi
fi
-AC_CHECK_PROG(HAVE_UNZIP,unzip,"yes","no",)
-if test "x$HAVE_UNZIP" = "xno" ; then
- AC_MSG_ERROR("Missing program: unzip")
-fi
-
-AC_CHECK_PROG(HAVE_ZIP,zip,"yes","no",)
-if test "x$HAVE_ZIP" = "xno" ; then
- AC_MSG_ERROR("Missing program: zip")
-fi
-
AC_PATH_PROG(CURL,curl,"no")
if test "x$CURL" = "xno" ; then
AC_MSG_ERROR("Missing program: curl")
@@ -585,6 +575,20 @@ if test "$platform_os" == "android"; then
fi
fi
+# darwin needs unzip/zip in Codesign.command
+if test "$platform_os" = "android" || test "$platform_os" = "osx" || test "$platform_os" = "ios"; then
+ AC_CHECK_PROG(HAVE_UNZIP,unzip,"yes","no",)
+ if test "x$HAVE_UNZIP" = "xno"; then
+ AC_MSG_ERROR("Missing program: unzip")
+ fi
+fi
+if test "$platform_os" = "osx" || test "$platform_os" = "ios"; then
+ AC_CHECK_PROG(HAVE_ZIP,zip,"yes","no",)
+ if test "x$HAVE_ZIP" = "xno"; then
+ AC_MSG_ERROR("Missing program: zip")
+ fi
+fi
+
# Some dumb checks to see if paths might be correct.
if [ ! `mkdir -p $prefix/$deps_dir/include` ]; then
AC_MSG_ERROR(unable to create $prefix/$deps_dir/include. verify that the path and permissions are correct.)