aboutsummaryrefslogtreecommitdiff
path: root/tools/depends/configure.ac
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2015-09-12 10:05:17 +0200
committerRainer Hochecker <fernetmenta@online.de>2015-12-06 20:33:50 +0100
commit1da2f07be715865bf7cf9731d7147dc4f43459be (patch)
treec34736dd0c6a3559d86ab7b2dc644c9604e4344e /tools/depends/configure.ac
parent091d54f5000b59afd12fdba465b547f264465063 (diff)
[depends] fix target raspberry-pi
Diffstat (limited to 'tools/depends/configure.ac')
-rw-r--r--tools/depends/configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/tools/depends/configure.ac b/tools/depends/configure.ac
index 478f5f0c98..ad5adbddd1 100644
--- a/tools/depends/configure.ac
+++ b/tools/depends/configure.ac
@@ -17,8 +17,7 @@ AC_ARG_WITH([toolchain],
AC_ARG_WITH([platform],
[AS_HELP_STRING([--with-platform],
[target platform [auto]])],
- [use_platform=$withval],
- [target_platform=$withval])
+ [use_platform=$withval])
AC_ARG_WITH([firmware],
[AS_HELP_STRING([--with-firmware],
@@ -305,7 +304,7 @@ esac
case $use_platform in
raspberry-pi)
- target_platform=raspberry_pi
+ target_platform=raspberry-pi
use_neon=no
use_cpu=arm1176jzf-s
platform_cflags="-mcpu=arm1176jzf-s -mtune=arm1176jzf-s -mfloat-abi=hard -mfpu=vfp"
@@ -313,7 +312,7 @@ case $use_platform in
platform_ldflags=""
;;
raspberry-pi2)
- target_platform=raspberry_pi
+ target_platform=raspberry-pi
use_neon=yes
use_cpu=cortex-a7
platform_cflags="-fPIC -mcpu=cortex-a7 -mfloat-abi=hard -mfpu=neon-vfpv4"
@@ -322,7 +321,7 @@ case $use_platform in
;;
esac
-if test "$target_platform" = "raspberry_pi" ; then
+if test "$target_platform" = "raspberry-pi" ; then
if test -d "${use_firmware}/opt/vc/include"; then
:
else
@@ -507,7 +506,7 @@ AC_SUBST(use_cpu)
AC_SUBST(use_toolchain)
AC_SUBST(use_build_toolchain)
AC_SUBST(use_tarballs)
-AC_SUBST(use_platform)
+AC_SUBST(target_platform)
AC_SUBST(use_firmware)
AC_SUBST(cross_compiling)
AC_SUBST(platform_cflags)