aboutsummaryrefslogtreecommitdiff
path: root/tools/Linux/packaging/debian
diff options
context:
space:
mode:
authorwattazoum <wattazoum@svn>2009-11-27 21:06:11 +0000
committerwattazoum <wattazoum@svn>2009-11-27 21:06:11 +0000
commit1b18a6df698438382e17236224ab22fc0ba176aa (patch)
tree0160c52878c8382c7ee22e6a4602b5110b576902 /tools/Linux/packaging/debian
parent10c2aa6b89f4526e5156261b4c99b13906e3eae4 (diff)
[packaging] fix package building scripts: dependencies + enable vdpau on Ubuntu + enable external libs on any other than Ubuntu
git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@25093 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'tools/Linux/packaging/debian')
-rw-r--r--tools/Linux/packaging/debian/control5
-rwxr-xr-xtools/Linux/packaging/debian/rules15
-rw-r--r--tools/Linux/packaging/debian/xbmc-live.install2
3 files changed, 18 insertions, 4 deletions
diff --git a/tools/Linux/packaging/debian/control b/tools/Linux/packaging/debian/control
index a7eb2f9be8..f695112424 100644
--- a/tools/Linux/packaging/debian/control
+++ b/tools/Linux/packaging/debian/control
@@ -6,7 +6,7 @@ Uploaders: Ouattara Oumar Aziz (alias wattazoum) <wattazoum@gmail.com>,
Andres Mejia <mcitadel@gmail.com>
DM-Upload-Allowed: yes
Build-Depends: debhelper (>= 7.0.50), python-support, cmake,
- autotools-dev, autoconf, automake, unzip, libboost-dev,
+ autotools-dev, autoconf, automake, unzip, libboost-dev, zip, libtool,
libgl1-mesa-dev | libgl-dev, libglu-dev, libglew-dev, libmad0-dev, libjpeg-dev,
libsamplerate-dev, libogg-dev, libvorbis-dev, libfreetype6-dev,
libfontconfig-dev, libbz2-dev, libfribidi-dev, libsqlite3-dev,
@@ -19,7 +19,8 @@ Build-Depends: debhelper (>= 7.0.50), python-support, cmake,
libswscale-dev, liba52-dev, libdts-dev, libmpeg2-4-dev, libass-dev,
libmpcdec-dev, libflac-dev, libwavpack-dev, python-dev, gawk, gperf,
nasm [!amd64], libcwiid1-dev, libbluetooth-dev, zlib1g-dev, libmms-dev,
- libsmbclient-dev, libfaad-dev, libiso9660-dev, libssl-dev,
+ libsmbclient-dev, libfaad-dev, libiso9660-dev, libssl-dev, libfaac-dev,
+ lsb-release,
Standards-Version: 3.8.3
Homepage: http://xbmc.org/
Vcs-Git: git://git.debian.org/git/pkg-multimedia/xbmc.git
diff --git a/tools/Linux/packaging/debian/rules b/tools/Linux/packaging/debian/rules
index d9a11a7889..0da99208e0 100755
--- a/tools/Linux/packaging/debian/rules
+++ b/tools/Linux/packaging/debian/rules
@@ -11,14 +11,21 @@ SVNVERSION ?= $(shell dpkg-parsechangelog | grep '^Version:' | sed 's/.*svn\([[:
# List of options to pass to configure. Can be overridden.
XBMC_CONFIG_OPTIONS ?= --host=$(DEB_HOST_GNU_TYPE) \
--build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --disable-ccache \
- --disable-dvdcss --enable-external-libraries --enable-avahi \
- --enable-goom CFLAGS="$(DEB_CFLAGS)" CXXFLAGS="$(DEB_CXXFLAGS)"
+ --enable-goom --enable-avahi \
+ CFLAGS="$(DEB_CFLAGS)" CXXFLAGS="$(DEB_CXXFLAGS)"
# Add the SVN revision if it exists in the changelog
ifeq (,$(findstring Version,$(SVNVERSION)))
XBMC_CONFIG_OPTIONS += SVN_REV="$(SVNVERSION)"
endif
+# Ubuntu or Debian specific options
+ifneq (Ubuntu,$(shell lsb_release -is))
+ XBMC_CONFIG_OPTIONS += --disable-dvdcss --enable-external-libraries
+else
+ XBMC_CONFIG_OPTIONS += --enable-vdpau
+endif
+
%:
dh $@
@@ -26,10 +33,14 @@ override_dh_clean:
dh_clean
override_dh_auto_configure:
+ ./bootstrap
./configure $(XBMC_CONFIG_OPTIONS)
override_dh_auto_install:
$(MAKE) install install-livedatas prefix=$(CURDIR)/debian/tmp/usr
+ mkdir -p $(CURDIR)/debian/tmp/etc/init/
+ cp $(CURDIR)/tools/XBMCLive/xbmc-live.conf $(CURDIR)/debian/tmp/etc/init/
+ cp $(CURDIR)/tools/XBMCLive/xbmc-live-install.conf $(CURDIR)/debian/tmp/etc/init/
find "debian/tmp/usr/share/xbmc" -regextype posix-extended \
-type f -iregex \
".*\.so|.*\.vis|.*\.xbs|.*xbmc\.bin|.*xbmc-xrandr" | \
diff --git a/tools/Linux/packaging/debian/xbmc-live.install b/tools/Linux/packaging/debian/xbmc-live.install
index 2732055d9c..4ec9962b26 100644
--- a/tools/Linux/packaging/debian/xbmc-live.install
+++ b/tools/Linux/packaging/debian/xbmc-live.install
@@ -2,3 +2,5 @@ usr/bin/diskmounter
usr/bin/installXBMC
usr/bin/runXBMC
usr/bin/setAlsaVolumes
+etc/init/xbmc-live.conf
+etc/init/xbmc-live-install.conf