aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordavilla <davilla@4pi.com>2011-10-15 13:57:13 -0400
committerdavilla <davilla@4pi.com>2011-10-15 13:57:13 -0400
commite9f4ea79c0a3f571621ac94fb8d09b300e1a737d (patch)
treef01f86487b0ac9e81883dc0a90caa9db2ece5a73 /configure.in
parentbefb23dd49d1b961cde09ed2cd34a6d2ad103ad3 (diff)
changed, remove libusb from libcec depends
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index b79f09baa4..c1a6b4aa75 100755
--- a/configure.in
+++ b/configure.in
@@ -1139,14 +1139,13 @@ if test "x$use_libcec" != "xno"; then
# libcec is dyloaded, so we need to check for its headers and link any depends.
PKG_CHECK_MODULES([CEC],[libcec = 0.7.0],,[use_libcec="no";AC_MSG_RESULT($libcec_disabled)])
if test "x$use_libcec" != "xno" && test "$host_vendor" != "apple"; then
- # libcec has libudev as depends under linux and we also need usb headers.
- PKG_CHECK_MODULES([USB],[libusb],,[use_libcec="no";AC_MSG_RESULT($libusb_not_found)])
+ # libcec has libudev as depends under linux.
PKG_CHECK_MODULES([UDEV],[libudev],,[use_libcec="no";AC_MSG_RESULT($libudev_not_found)])
fi
if test "x$use_libcec" != "xno"; then
if test "$host_vendor" != "apple"; then
- # if linux, bring in usb and udev cflags but only udev as lib.
- INCLUDES="$INCLUDES $USB_CFLAGS $UDEV_CFLAGS";LIBS="$LIBS $UDEV_LIBS"
+ # if linux, bring in udev cflags and add lib.
+ INCLUDES="$INCLUDES $UDEV_CFLAGS";LIBS="$LIBS $UDEV_LIBS"
USE_LIBUDEV=1;AC_DEFINE([HAVE_LIBUDEV],[1],["Define to 1 if libudev is installed"])
fi
INCLUDES="$INCLUDES $CEC_CFLAGS"