aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorelupus <elupus@xbmc.org>2011-10-08 15:15:33 +0200
committerelupus <elupus@xbmc.org>2012-04-11 00:06:22 +0200
commit9b1dd39eb74828c050fac88a00c51b06db9dd7c8 (patch)
treecd732b3603b99c46b303aebe2c9120dbd8fd80a6 /configure.in
parentc0e25fd62725550ec96e391c6c1750ab2282cbd1 (diff)
[bluray] Delete support for older libbluray
xbmc will abort configure if an old libbluray is found and configure is auto or yes. To skip libbluray support in that case explicitly disable it.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 11b6bc1ca6..b4c87a290c 100755
--- a/configure.in
+++ b/configure.in
@@ -777,21 +777,9 @@ AS_CASE([x$use_libbluray],
[AC_LANG_PROGRAM(
[#include <libbluray/bluray.h>]
,[bd_get_playlist_info(0, 0)])]
- ,[AC_MSG_RESULT(version has old angle api)
- AC_DEFINE([HAVE_LIBBLURAY_NOANGLE],[],[System has an old api libbluray without angle support])]
+ ,[AC_MSG_ERROR(version has old angle api which is not supported, if you want to continue disable libbluray support)]
,[AC_MSG_RESULT(normal)]
)
-
- AC_MSG_CHECKING([for libbluray log control])
- AC_LINK_IFELSE(
- [AC_LANG_PROGRAM(
- [#include <libbluray/bluray.h>
- #include <libbluray/log_control.h>]
- ,[bd_set_debug_mask(0)])]
- , AC_MSG_RESULT(yes)
- ,[AC_MSG_RESULT(no)
- AC_DEFINE([HAVE_LIBBLURAY_NOLOGCONTROL],[],[System has an old api libbluray without log support])]
- )
)
],[
# AC_DEFINE([HAVE_LIBBLURAY], 0, [System has libbluray library])