aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorspiff <spiff@xbmc.org>2012-05-02 18:33:49 +0200
committerspiff <spiff@xbmc.org>2012-05-02 22:06:59 +0200
commit6ad8770d9f6c062249fd60c659c6f3c81541d55f (patch)
treed3df7e259349700501ac88bc5335508896a9b069 /configure.in
parent99d768292354fbaa0b7c0b9641ca834dc2b4425a (diff)
fixed: don't use a hard-coded name for the mp3lame library
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f5c6952546..9082e71a3e 100755
--- a/configure.in
+++ b/configure.in
@@ -694,6 +694,7 @@ AC_CHECK_HEADER([vorbis/vorbisenc.h],, AC_MSG_ERROR($missing_library))
AC_CHECK_HEADER([libmodplug/modplug.h],, AC_MSG_ERROR($missing_library))
AC_CHECK_HEADER([curl/curl.h],, AC_MSG_ERROR($missing_library))
AC_CHECK_HEADER([FLAC/stream_decoder.h],, AC_MSG_ERROR($missing_library))
+AC_CHECK_HEADER([lame/lame.h],, AC_MSG_ERROR($missing_headers))
# we need to check for the header because if it exists we set the openssl
# and gcrypt MT callback hooks. This is mostly so that libcurl operates
@@ -808,12 +809,15 @@ XB_FIND_SONAME([OGG], [ogg])
XB_FIND_SONAME([CURL], [curl])
XB_FIND_SONAME([FLAC], [FLAC])
XB_FIND_SONAME([VORBIS], [vorbis])
-XB_FIND_SONAME([VORBISENC], [vorbisenc])
XB_FIND_SONAME([VORBISFILE], [vorbisfile])
XB_FIND_SONAME([MODPLUG], [modplug])
XB_FIND_SONAME([ASS], [ass])
XB_FIND_SONAME([MPEG2], [mpeg2])
+# Audio encoders
+XB_FIND_SONAME([LAMEENC], [mp3lame])
+XB_FIND_SONAME([VORBISENC], [vorbisenc])
+
# WebServer
if test "$use_webserver" = "yes"; then
AC_CHECK_LIB([microhttpd], [main],, AC_MSG_ERROR($missing_library))