aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjimfcarroll <thecarrolls@jiminger.com>2011-11-15 15:42:28 -0800
committerjimfcarroll <thecarrolls@jiminger.com>2011-11-15 15:42:28 -0800
commitf587ca90e1c6b5fbbcb80bdc04048a4e0ca278de (patch)
tree667f6740372da990224f6dabd786ee6158529247 /configure.in
parent182d3cfa1f7f4623e3bf56e8e638ba32934d31c8 (diff)
parent8541cc38192985425704147c0e417203d7d685b6 (diff)
Merge pull request #527 from jimfcarroll/ssl-locking
Added a utility to set the ssl library's MT hooks.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fa110f87da..bca9239e33 100755
--- a/configure.in
+++ b/configure.in
@@ -698,6 +698,18 @@ AC_CHECK_HEADER([vorbis/vorbisenc.h],, AC_MSG_ERROR($missing_library))
AC_CHECK_HEADER([libmodplug/modplug.h],, AC_MSG_ERROR($missing_library))
AC_CHECK_HEADER([curl/curl.h],, AC_MSG_ERROR($missing_library))
AC_CHECK_HEADER([FLAC/stream_decoder.h],, AC_MSG_ERROR($missing_library))
+
+# we need to check for the header because if it exists we set the openssl
+# and gcrypt MT callback hooks. This is mostly so that libcurl operates
+# in MT manner correctly.
+AC_CHECK_HEADER([openssl/crypto.h], AC_DEFINE([HAVE_OPENSSL],[1],[Define if we have openssl]),)
+AC_CHECK_HEADER([gcrypt.h], gcrypt_headers_available=yes,gcrypt_headers_available=no)
+if test "$gcrypt_headers_available" = "yes"; then
+ # if we have the headers then we must have the lib
+ AC_CHECK_LIB([gcrypt],[gcry_control],, AC_MSG_ERROR($missing_library))
+ AC_DEFINE([HAVE_GCRYPT],[1],[Define if we have gcrypt])
+fi
+
AC_CHECK_LIB([bz2], [main],, AC_MSG_ERROR($missing_library))
AC_CHECK_LIB([jpeg], [main],, AC_MSG_ERROR($missing_library)) # check for cximage
AC_CHECK_LIB([tiff], [main],, AC_MSG_ERROR($missing_library))