aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTobias Arrskog <topfs2@xbmc.org>2014-09-07 11:00:36 +0200
committerTobias Arrskog <topfs2@xbmc.org>2014-09-07 11:00:36 +0200
commit630f930d4c9c33230e9ff7df24f93afb3f05881f (patch)
tree55977e30453267a66461a32c37893facb39afd7c /configure.in
parent762fbdf458d6465d7453fe8dc01f502ceb5d0300 (diff)
parent7c77d9c6b051d2ee6db42124a23848a6c6ef3d35 (diff)
Merge pull request #5315 from bkuhls/dbus
build: make D-Bus configurable
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e40d768859..a82483e82d 100644
--- a/configure.in
+++ b/configure.in
@@ -164,6 +164,7 @@ spectrum_disabled="== SPECTRUM disabled =="
goom_enabled="== GOOM enabled. =="
goom_disabled="== GOOM disabled. =="
alsa_disabled="== ALSA support disabled. =="
+dbus_disabled="== DBUS support disabled. =="
rsxs_enabled="== RSXS enabled. =="
rsxs_disabled="== RSXS disabled. =="
fishbmc_enabled="== FishBMC enabled. =="
@@ -377,6 +378,12 @@ AC_ARG_ENABLE([alsa],
[use_alsa=$enableval],
[use_alsa=yes])
+AC_ARG_ENABLE([dbus],
+ [AS_HELP_STRING([--disable-dbus],
+ [disable DBUS support])],
+ [use_dbus=$enableval],
+ [use_dbus=yes])
+
AC_ARG_ENABLE([pulse],
[AS_HELP_STRING([--enable-pulse],
[enable PulseAudio support (default is auto)])],
@@ -1202,10 +1209,14 @@ if test "x$use_alsa" != "xno"; then
[INCLUDES="$INCLUDES $ALSA_CFLAGS"; LIBS="$LIBS $ALSA_LIBS"; use_alsa=yes],
AC_MSG_NOTICE($alsa_not_found); use_alsa=no)
fi
+if test "x$use_dbus" != "xno"; then
PKG_CHECK_MODULES([DBUS], [dbus-1],
[INCLUDES="$INCLUDES $DBUS_CFLAGS"; LIBS="$LIBS $DBUS_LIBS"; use_dbus=yes]; \
AC_DEFINE([HAVE_DBUS],[1],["Define to 1 if dbus is installed"]),
AC_MSG_NOTICE($missing_library); use_dbus=no)
+else
+ AC_MSG_NOTICE($dbus_disabled)
+fi
if test "x$use_sdl" != "xno"; then
PKG_CHECK_MODULES([SDL], [sdl],
[INCLUDES="$INCLUDES $SDL_CFLAGS"; LIBS="$LIBS $SDL_LIBS"],