aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordavilla <davilla@4pi.com>2012-07-19 22:28:13 -0400
committerCory Fields <theuni-nospam-@xbmc.org>2012-08-08 19:14:51 -0400
commit2d9b3a544d0a5d5f7b0564fd1a9ad216bcb6aaab (patch)
tree863ca6062b5f76b5c9866f7a5a6f410b97ea4654 /configure.in
parent9f91bd7d4181e0fc4628dca3cab7f3695052c53d (diff)
[droid] add new internal player for amlogic based SoCs
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 17ba34b4e5..5e8b488ad7 100644
--- a/configure.in
+++ b/configure.in
@@ -475,7 +475,7 @@ AC_ARG_ENABLE([libcap],
AC_ARG_ENABLE([player],
[AS_HELP_STRING([--enable-player],
- [enable additional players from a list of comma separated names, (default is none)])],
+ [enable additional players from a list of comma separated names, (default is none, choices are amlplayer)])],
[add_players=$enableval],
[add_players=no])
@@ -1648,6 +1648,14 @@ AC_CHECK_HEADERS([yajl/yajl_version.h], [], [
AC_DEFINE(YAJL_MAJOR, 1, [yajl version 1])
], [])
+# additional internal players
+case $add_players in
+ *amlplayer*)
+ AC_CHECK_HEADER([amlplayer/amports/amstream.h],, AC_MSG_ERROR($missing_headers))
+ XB_ADD_PLAYER([AMLPLAYER], [amlplayer])
+ ;;
+esac
+
# platform specific bin utilities
if test "$host_vendor" != "apple" ; then
AC_CHECK_PROG(HAVE_GAWK,gawk,"yes","no",)
@@ -2114,6 +2122,7 @@ OUTPUT_FILES="Makefile \
xbmc/cores/dvdplayer/DVDSubtitles/Makefile \
xbmc/cores/AudioEngine/Makefile \
xbmc/cores/paplayer/Makefile \
+ xbmc/cores/amlplayer/Makefile \
lib/timidity/Makefile \
lib/xbadpcm/Makefile \
lib/asap/Makefile \