aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCory Fields <theuni-nospam-@xbmc.org>2013-03-08 05:54:27 -0500
committerCory Fields <theuni-nospam-@xbmc.org>2013-03-11 00:23:15 -0400
commit7d1c5238d1ee0b8ef395d47edb324be020e5951d (patch)
tree6f4bcc1aa23f7231b06c7a8d1bb0074c91e2af24 /configure.in
parent88baf88d948314fd0c6a75975193cec2b737f7ae (diff)
depends: add liblog check, it may not be included by the toolchain
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d59bbd2740..ab418deaa4 100644
--- a/configure.in
+++ b/configure.in
@@ -1012,6 +1012,7 @@ if test "$target_platform" = "target_android" ; then
#android hack for static python. Required to maintain correct linking order.
AC_CHECK_LIB([python$PYTHON_VERSION], [main],, AC_MSG_ERROR($missing_library))
AC_CHECK_LIB([android], [main],, AC_MSG_ERROR($missing_library))
+ AC_CHECK_LIB([log], [__android_log_vprint],, AC_MSG_ERROR($missing_library))
fi
PKG_CHECK_MODULES([FRIBIDI], [fribidi],
[INCLUDES="$INCLUDES $FRIBIDI_CFLAGS"; LIBS="$LIBS $FRIBIDI_LIBS"],