aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorceros7 <ceros7@svn>2010-03-26 04:06:21 +0000
committerceros7 <ceros7@svn>2010-03-26 04:06:21 +0000
commit5d5d85940d0e0bae511c24abe40bae5314609b44 (patch)
tree13231001831ccefaed421e0a52179ff0bb6c0043 /configure.in
parent3bd3b5861d2a0b561fc5e01d0bd138039fff79ab (diff)
Automatically install config.guess and config.sub from configure script if not
in the source tree already git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@28821 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 248353d47b..65c30a5934 100644
--- a/configure.in
+++ b/configure.in
@@ -9,13 +9,15 @@ AH_TOP([#pragma once])
# Ensure config.guess and config.sub exist and is executable
# Also install latest version of these files if available
AC_MSG_NOTICE([Ensuring config.guess and config.sub exist and is executable])
-test -f config.guess && chmod a+x config.guess
+test -f config.guess || cp -f /usr/share/misc/config.guess config.guess
+chmod a+x config.guess
if [[ -x /usr/share/misc/config.guess ]] && \
[[ $($PWD/config.guess -t | sed 's/-//g') -lt \
$(/usr/share/misc/config.guess -t | sed 's/-//g') ]]; then
cp -f /usr/share/misc/config.guess config.guess
fi
-test -f config.sub && chmod a+x config.sub
+test -f config.sub || cp -f /usr/share/misc/config.sub config.sub
+chmod a+x config.sub
if [[ -x /usr/share/misc/config.sub ]] && \
[[ $($PWD/config.sub -t | sed 's/-//g') -lt \
$(/usr/share/misc/config.sub -t | sed 's/-//g') ]]; then