aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2012-12-14 14:19:55 +0100
committerwsnipex <wsnipex@a1.net>2012-12-14 14:21:34 +0100
commit2f4a1868897a797b69b9d2795177d6c62b3e3ba0 (patch)
tree22a587381f1648b3bf83ec19c024bd994c702eac /configure.in
parent04d5463f66a98502f4995f93dadb687cf8a252a3 (diff)
fix configure warnings when lame lib exists but not the headers (closes #13647)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 10 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 4db7fdef20..f760971b67 100644
--- a/configure.in
+++ b/configure.in
@@ -1078,11 +1078,16 @@ XB_FIND_SONAME([ASS], [ass])
XB_FIND_SONAME([MPEG2], [mpeg2])
# Audio encoders
-if test "x$use_libmp3lame" != "xno"; then
- XB_FIND_SONAME([LAMEENC], [mp3lame], [use_libmp3lame])
- if test "x$use_libmp3lame" != "xno"; then
- AC_CHECK_HEADER([lame/lame.h],, AC_MSG_ERROR($missing_headers))
- fi
+if test "x$use_libmp3lame" = "xyes"; then
+ AC_CHECK_HEADER([lame/lame.h],
+ [XB_FIND_SONAME([LAMEENC], [mp3lame], [use_libmp3lame])],
+ AC_MSG_ERROR(lame/lame.h not found)
+ )
+elif test "x$use_libmp3lame" != "xno"; then
+ AC_CHECK_HEADER([lame/lame.h],
+ [XB_FIND_SONAME([LAMEENC], [mp3lame], [use_libmp3lame])],
+ AC_MSG_NOTICE(lame/lame.h not found)
+ )
fi
AS_CASE([x$use_libmp3lame],
[xno],[