aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTrent Nelson <trent.a.b.nelson@gmail.com>2014-02-23 17:54:13 -0500
committerTrent Nelson <trent.a.b.nelson@gmail.com>2014-02-23 17:54:13 -0500
commit5e111e741ec7563a57a979f990d095145abf6c2e (patch)
tree3038481743a94a2ea582bbdc65d1c25bbe895382 /configure.in
parent0ee41b53dd14c40eeef7ae03033dfc88576bc6f4 (diff)
parent26c44f59885cbf6a18fa02546e730fad567f2550 (diff)
Merge pull request #4154 from sraue/ffmpeg-static-fixes
configure.in: enable FFMPEG static build for ARM, some cleanups. Tested ...
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 42dd00e706..7390167cdd 100644
--- a/configure.in
+++ b/configure.in
@@ -625,24 +625,22 @@ case $host in
use_sdl=no
use_x11=no
build_shared_lib=yes
- ;;
+ ;;
i*86*-linux-gnu*|i*86*-*-linux-uclibc*)
ARCH="i486-linux"
if test "$use_cpu" = "no" -a "$cross_compiling" = "yes"; then
use_arch="x86"
use_cpu="i686"
- else
- target_platform=target_linux
fi
+ use_static_ffmpeg=yes
;;
x86_64-*-linux-gnu*|x86_64-*-linux-uclibc*)
ARCH="x86_64-linux"
if test "$use_cpu" = "no" -a "$cross_compiling" = "yes"; then
use_arch="x86_64"
use_cpu="x86_64"
- else
- target_platform=target_linux
fi
+ use_static_ffmpeg=yes
;;
i386-*-freebsd*)
ARCH="x86-freebsd"
@@ -698,6 +696,7 @@ case $host in
use_sdl=no
use_x11=no
use_wayland=no
+ use_static_ffmpeg=yes
;;
arm*-*linux-android*)
target_platform=target_android
@@ -875,9 +874,8 @@ elif test "$use_arch" = "arm"; then
fi
fi
fi
-if test "$target_platform" = "target_linux"; then
+if test "$use_static_ffmpeg" = "yes"; then
USE_STATIC_FFMPEG=1
- use_static_ffmpeg=yes
AC_DEFINE([USE_STATIC_FFMPEG], [1], [link ffmpeg statically])
# ffmpeg may depend on gnutls and vorbisenc, we add those libs at the end of linker
# command in order to resolve any missing symbols
@@ -2804,7 +2802,6 @@ XB_CONFIG_MODULE([lib/ffmpeg], [
LDFLAGS="$(echo "$LDFLAGS" | sed "s/-Wl,-Bsymbolic-functions//g")" \
./configure \
--extra-cflags="$PASSED_CFLAGS $FFMPEG_EXTRACFLAGS" \
- --disable-static \
`if test "$use_debug" = "no"; then echo --disable-debug; fi` \
`if test "$cross_compiling" = "yes"; then echo --enable-cross-compile; fi` \
`if test "$use_arch" != "no"; then echo --arch=$use_arch; fi`\
@@ -2828,7 +2825,7 @@ XB_CONFIG_MODULE([lib/ffmpeg], [
--disable-ffserver \
--disable-ffmpeg \
--disable-crystalhd \
- `if test "$use_static_ffmpeg" = "yes"; then echo --enable-static; else echo --enable-shared; fi` \
+ `if test "$use_static_ffmpeg" = "yes"; then echo --enable-static --disable-shared; else echo --disable-static --enable-shared; fi` \
--disable-doc \
--enable-postproc \
--enable-gpl \