aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordavilla <davilla@svn>2010-05-20 03:48:34 +0000
committerdavilla <davilla@svn>2010-05-20 03:48:34 +0000
commitc530dcef746bb285c45301d3157c4b543c0e9816 (patch)
tree82c25e5763e2d015fee105ddcb1804944c0d5924 /configure.in
parent3ea2a99e527af14255d452f81c31c818d705d48d (diff)
move use_webserver check
git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@30328 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 11 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 27efaa7a97..ae8274d87d 100644
--- a/configure.in
+++ b/configure.in
@@ -399,17 +399,6 @@ else
fi
fi
-if test "$host_vendor" != "apple" ; then
- if test "$use_webserver" = "yes"; then
- AC_CHECK_LIB([microhttpd], [main],, AC_MSG_ERROR($missing_library))
- fi
-else
- if test "$use_webserver" = "yes"; then
- AC_DEFINE([HAVE_LIBMICROHTTPD], [1],)
- fi
-fi
-
-
# platform independent libraries
AC_CHECK_HEADER([mad.h],, AC_MSG_ERROR($missing_library))
AC_CHECK_HEADER([jpeglib.h],, AC_MSG_ERROR($missing_library))
@@ -566,6 +555,17 @@ if test "$host_vendor" != "apple"; then
XB_FIND_SONAME([VORBIS], [vorbis])
fi
+# WebServer
+if test "$host_vendor" != "apple" ; then
+ if test "$use_webserver" = "yes"; then
+ AC_CHECK_LIB([microhttpd], [main],, AC_MSG_ERROR($missing_library))
+ fi
+else
+ if test "$use_webserver" = "yes"; then
+ AC_DEFINE([HAVE_LIBMICROHTTPD], [1],)
+ fi
+fi
+
# PulseAudio
if test "x$use_pulse" != "xno"; then
if test "$host_vendor" = "apple" ; then