aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorspiff_ <spiff_@svn>2010-06-08 13:19:58 +0000
committerspiff_ <spiff_@svn>2010-06-08 13:19:58 +0000
commit1ed9ffa9d1b5e3724a29bb156deb5bf90c8be0f7 (patch)
tree73b9420be6c8d71aeb0bcb0185ca84a95e282ff6 /configure.in
parent5892e799cb32f7d8ead86605b0d430162171405e (diff)
added: webm support through libvpx
git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@30961 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8f21205eb6..a63ca22aeb 100644
--- a/configure.in
+++ b/configure.in
@@ -46,6 +46,7 @@ openmax_disabled="== OpenMax support manually disabled. =="
openmax_not_found="== Could not find libnvomx. OpenMax support disabled. =="
libass_using_internal="== External Libass not found, using internal. =="
ssh_not_found="== Could not find libssh. SSH FTP VFS support disabled. =="
+libvpx_not_found="== Could not find libvpx. WebM support disabled. =="
# External library message strings
external_libraries_enabled="== Use of all supported external libraries enabled. =="
@@ -669,6 +670,10 @@ else
fi
fi
+# WebM
+AC_CHECK_LIB([vpx], [main],use_vpx=yes,
+use_vpx=no;AC_MSG_RESULT($vpx_not_found))
+
### External libraries checks
# External FFmpeg
if test "$use_external_ffmpeg" = "yes"; then
@@ -723,6 +728,12 @@ else
AC_DEFINE([PIX_FMT_VDPAU_MPEG4_IN_AVUTIL], [1], [Whether AVUtil defines PIX_FMT_VDPAU_MPEG4.])
fi
+if test "$use_vpx" = "yes"; then
+ USE_VPX=1
+else
+ USE_VPX=0
+fi
+
# External liba52 if deprecated a52 support is enabled
if test "$use_liba52" = "yes" && "$use_external_liba52" = "yes"; then
AC_CHECK_LIB([a52], [main],, AC_MSG_ERROR($missing_library))
@@ -1205,6 +1216,12 @@ else
final_message="$final_message\n Webserver:\tNo"
fi
+if test "$use_vpx" = "yes"; then
+ final_message="$final_message\n WebM support:\tYes"
+else
+ final_message="$final_message\n WebM support:\tNo"
+fi
+
if test "$use_libdts" = "yes"; then
USE_LIBDTS_DECODER=1
AC_DEFINE([USE_LIBDTS_DECODER], [1], [Define to 1 to enable deprecated libdts support])
@@ -1363,6 +1380,7 @@ AC_SUBST(USE_PYTHON2_4)
AC_SUBST(OUTPUT_FILES)
AC_SUBST(HAVE_XBMC_NONFREE)
AC_SUBST(USE_ASAP_CODEC)
+AC_SUBST(USE_VPX)
AC_SUBST(LIBCURL_BASENAME)
AC_SUBST(LIBFLAC_BASENAME)
AC_SUBST(LIBVORBISFILE_BASENAME)
@@ -1499,6 +1517,7 @@ XB_CONFIG_MODULE([xbmc/cores/dvdplayer/Codecs/ffmpeg], [
--disable-ffmpeg \
--enable-shared \
--disable-decoder=mpeg_xvmc \
+ `if test "$use_vpx" = "yes"; then echo --enable-libvpx; fi` \
--enable-postproc \
--enable-gpl \
--enable-protocol=http \
@@ -1528,6 +1547,7 @@ XB_CONFIG_MODULE([xbmc/cores/dvdplayer/Codecs/ffmpeg], [
--enable-encoder=aac \
`if test "$use_ffmpeg_libvorbis" == "yes"; then echo --enable-libvorbis --enable-muxer=ogg --enable-encoder=libvorbis; else echo --disable-libvorbis; fi` \
--disable-decoder=mpeg_xvmc \
+ `if test "$use_vpx" = "yes"; then echo --enable-libvpx; fi` \
--disable-devices \
--disable-ffplay \
--disable-ffserver \